[HELP] The command failed. Windows reported the error:

Discussion in 'Mapping Questions & Discussion' started by marsbar20, Apr 19, 2012.

  1. marsbar20

    marsbar20 L1: Registered

    Messages:
    13
    Positive Ratings:
    1
    I have been working on a map for just over a month now and when i try to compile i get a pop up with this error and a "yes" "no" button:
    The command failed. Windows reported the error: "The system cannot find the file specified."

    I did get a new computer, though i'm not sure if that is the problem.

    EDIT:

    I don't know what happened but it started working again, even though i didn't change anything.
     
    Last edited: Apr 20, 2012
  2. Kiddnils

    Kiddnils L3: Member

    Messages:
    140
    Positive Ratings:
    113
    Make sure the file is saved in the right place. In addition don't use spaces in the mapname. If that doesn't help look for errors in the compile log.
     
  3. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,920
    Depending on when the error is appearing, it basically means vbsp isn't running or is crashing. Find the vbsp section of your compile log from hammer(not the file in mapsrc) and post that.
     
  4. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,767
    Other causes of this error could be specifying a save location that differs from the directory the compile processes reference (vbsp, vvis, vrad). I mention this as you said you had a new computer.

    But as YM said, it's likely that the compile is being interrupted.
     
  5. marsbar20

    marsbar20 L1: Registered

    Messages:
    13
    Positive Ratings:
    1
    I'm guessing that the stuff in bold is the vbsp section though I may be wrong so I posted the rest of it.

     
  6. Wander

    Wander L3: Member

    Messages:
    148
    Positive Ratings:
    50
    did you take your compile log through interlopers ?

    Cause that says what the problem is, you have displacements with the nodraw texture
     
  7. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    5,463
    You have displacement brush(es) that don't have a rendered texture. You need to find those displacements, and fix it.
     
  8. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,767
    *This is usually because of nodraw on a displacement. You can easily search for this hidden face by turning off all visgroups and toggle displacements/nodraw to narrow your search down to only the important stuff.