Help! Payload Cart under map!

Discussion in 'Mapping Questions & Discussion' started by AlphaOwl, Oct 5, 2017.

  1. AlphaOwl

    AlphaOwl L1: Registered

    Messages:
    21
    Positive Ratings:
    2
    I'm currently working on a payload map, and I believe I've put in all the correct outputs and properties, but somehow my payload cart spawns below my map. Any suggestions? I'm currently stuck, and I would like to troubleshoot this before progressing my map.

    payloadmissing.jpg wherescart.jpg
     
  2. Crash

    aa Crash func_nerd

    Messages:
    3,190
    Positive Ratings:
    4,916
    Make sure helpers are turned on :helpers: and select your whole cart. Look under it as low as it's spawning in relation to the first track point, for a little blue sphere in the 3d view, or a small hollow circle in a 2d view.

    This is the origin point, and I'm betting it got below the cart on accident. Dragging it into the middle of the cart (or centering origins via right clicking in a 2d view with it selected, I believe) will put it back in place.

    If it isn't there, we might need to dig more.
     
  3. AlphaOwl

    AlphaOwl L1: Registered

    Messages:
    21
    Positive Ratings:
    2
    I found the sphere and centered it to the entity, but multiple tries still got me the same result: Somehow the cart still teleports in a general same position under the map bouncing up and down. I'm not really sure what it can be, but hopefully I can find out.
     
  4. Crash

    aa Crash func_nerd

    Messages:
    3,190
    Positive Ratings:
    4,916
    Are you sure the map is updating? Like try placing a brush somewhere and recompiling and seeing if it's there.
     
    • Agree Agree x 1
  5. AlphaOwl

    AlphaOwl L1: Registered

    Messages:
    21
    Positive Ratings:
    2
  6. pennsyrail

    pennsyrail L2: Junior Member

    Messages:
    62
    Positive Ratings:
    8
    can you post a copy of a map for us to view?
     
  7. pennsyrail

    pennsyrail L2: Junior Member

    Messages:
    62
    Positive Ratings:
    8
    may possibly be helpful.
     
  8. AlphaOwl

    AlphaOwl L1: Registered

    Messages:
    21
    Positive Ratings:
    2
    It's a WIP, but here's what I have.
     

    Attached Files:

  9. Vel0city

    aa Vel0city func_fish

    Messages:
    1,931
    Positive Ratings:
    1,540
    Post your compile log as well.
     
  10. AlphaOwl

    AlphaOwl L1: Registered

    Messages:
    21
    Positive Ratings:
    2
    I think this is it.
     

    Attached Files:

  11. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    You can just copy the log after compiling and post it in a spoiler bracket like this:


    No errors in the log though.

    Looking at the map, the error is porbably that you gave the track_train a parent: the prop_physics_override of the payload. Just remove the parent.

    On another note, you might wanna increase your grid size. While you appearently used a grid size of 4, which isn't compleetly horrible, you could increase it to 16, since you are just making a basic layout and all brushes you used are 16 units thick. So working on a grid size of 16 will be more organized later when your vmf gets more complex.

    Also don't make a giant skybox-box to seal your level. I know it's just alpha, but your map is currently easily sealable with just two skybox brushes, one at the top, one above blue spawn. Just saying in case you didn't know how to skybox properly.
     
  12. AlphaOwl

    AlphaOwl L1: Registered

    Messages:
    21
    Positive Ratings:
    2
    Well, the cart's back. I think all I have to do now is find why the payload's trigger is not working. Don't worry, I can probably find it on a thread somewhere around here. Thanks everyone!