Help packing textures with PackBSP after Steampipe

Discussion in 'Tutorials & Resources' started by Werewolf, Jul 15, 2013.

  1. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    752
    Positive Ratings:
    212
    I've been trying to pack some custom textures into my map with PackBSP and still getting missing textures. I had done this uploaded the map to our server for some play testing, yet when people played they complained of missing textures.

    When I tried re-packing I noticed something - some of the standard assets that should be there already were also not being packed!

    This is the first time I've had to pack a map since the SteamPipe update, so I suspect I have not set something right. Could someone advise me on how and what I need to do to fix this please?
     
  2. henke37

    aa henke37

    Messages:
    1,876
    Positive Ratings:
    440
    I would just sit down and manually write a list file for bspzip.exe. It takes a little time yes, but this way you know who to blame.
     
  3. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    752
    Positive Ratings:
    212
    How would I do that exactly? Is there a guide somewhere on this?
     
  4. henke37

    aa henke37

    Messages:
    1,876
    Positive Ratings:
    440
    Yup, it's on the VDC.
     
    • Thanks Thanks x 1
  5. Idolon

    aa Idolon the worst admin

    Messages:
    1,484
    Positive Ratings:
    4,317
    Alternatively, get VIDE.
     
    • Thanks Thanks x 1
  6. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    752
    Positive Ratings:
    212
    I've got VIDE, but I can't figure how to use it exactly.

    In fact, I have now tried using PackBSP, PakRat and VIDE on 3 identical versions of the same map, sent over to friends and each time I get told that they are missing textures.

    It's actually getting annoying now. Might there be something wrong with my settings or something?
     
  7. Blade x64

    aa Blade x64 Logical insanity

    Messages:
    200
    Positive Ratings:
    450
    There is nothing wrong with your settings. PackBSP was made well before the steampipe update and the creator has not updated PackBSP to work with it. Try making a symbolic link so that username/team fortress 2/tf leads to common/Team Fortress 2/tf/download/.
     
  8. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Goddamnit, you mean I spent all those hours of blood and tears to read GCF files and then Valve just... makes it easier? :p

    • Bad News: I've stopped working on PackBSP... I haven't touched any Source-engine game (let alone dev tools) in many months, and my attempts to get any feedback or help from Valve went unanswered. (Even though their office is just a few blocks away.)
    • Not-as-bad News: It's been open-sourced for over two years now... So if someone else has a fix they want to incorporate, I'd be more than happy to try fitting it in.
     
    • Thanks Thanks x 1
    Last edited: Aug 7, 2013
  9. FiLi

    FiLi L4: Comfortable Member

    Messages:
    195
    Positive Ratings:
    50
    I always used pakrat. It can be kind of finicky, but it worked out.
     
  10. Werewolf

    aa Werewolf Probably not a real Werewolf

    Messages:
    752
    Positive Ratings:
    212
    Oh forgot about this thread.

    I tried a sybolic link, still nothing. I've tried copying all the custom stuff to the older folders yet still nothing works. It's really annoying because I have a map I want to get play tested and I can't because it wont pack files.
     
  11. Blade x64

    aa Blade x64 Logical insanity

    Messages:
    200
    Positive Ratings:
    450