Help - My Map Crashes TF2

Discussion in 'Mapping Questions & Discussion' started by Undead Axe, Jun 20, 2009.

  1. Undead Axe

    Undead Axe L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    I have already posted this on the TF2 forums with no avail so I came here looking for help:

    I started my TF2 map about 2 months ago, worked on it for a week then stopped. I came back a few days ago to start work on it again.

    It was all working fine until, at one point, I loaded up my map using 'File/Run Map' and it launched TF2 and reached the part where it sais loading the the bottom right and nothing else. It then crashed to desktop.

    This keeps happening and I have tried rebooting the computer. I googled the problem and came up with the same issue although all relating to different programs and giving me different instructions.

    I would be grateful for any help you could provide me with.

    Below is the error details I get on the crash to desktop.



    Another thing I noticed is that when I press run and the compile process window comes up it has about 70 of this error:

     
  2. Micnax

    aa Micnax I maek map

    Messages:
    2,057
    Positive Ratings:
    1,387
    In Hammer, go to Map -> Check for Problems, and select all the problems (if any, most of them will be HammerID ones) and click Fix. Did the trick for me :p
     
  3. AntonJ3000

    AntonJ3000 I am inactive and make horrible maps

    Messages:
    401
    Positive Ratings:
    89
    Post your compile log (The log that comes out after you did run map)

    The whole one, then it'd probably some error that you missed.

    Also, If you set some stuff in "Map Properties" like map names or something like that, It can be the reason, that was the crash reason for one of my map crashes.
     
  4. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    "error: material WATER/WATER_2FORT_BENEATH_DX80 doesn't have a $bottommaterial "

    You're using the wrong water material. Do NOT use a water material that has suffixes (_beneath, _dx##, and others). They are supporting sub-materials for the main one (water_2fort), which is the one you should be using in Hammer.

    However, this probably shouldn't be crashing you. Map based crashes have the most varied and numerous causes of any error, you'd need to give more information.
     
  5. Undead Axe

    Undead Axe L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    I did run it through the checker thing but it didnt make any sense to me.
    Sorry If I am missing somthing obvious but I am kind of overwhelmed at the moment.

     
    Last edited: Jun 20, 2009
  6. zornor

    zornor L4: Comfortable Member

    Messages:
    195
    Positive Ratings:
    23
    Probably because you have a leak, which means that there's an entity outside your map, or your map hasn't been sealed correctly.

    For more information, here's a link to the Valve Developer Community wiki on leaks.
    http://developer.valvesoftware.com/wiki/Leaks
     
  7. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    You need to fix that water. That's an obvious error so a good place to start.

    You have alot of these too
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (512.0 10240.0 -40.0)
    Leaf 0 contents:
    Leaf 1 contents: CONTENTS_SOLID
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID
    Candidate brush IDs:


    It doesn't give a brush id so you have to search by coords. I highlighted them, they are very close to the center of the grid. Just move your mouse over the viewport and look in lower right hand corner, you'll see the mouse coords. Once you match them up you'll know where to look for problems.

    Fix the water first, it could be the problem.