*help* metal texture are missing

Discussion in 'Mapping Questions & Discussion' started by JLx14, Sep 27, 2009.

  1. JLx14

    JLx14 L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    every time i make a map the texture for anything metal are the purple and black texture thing. as well as any water with rich texture. So can you help me?
     
  2. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    145
    You probably need to build your cubemaps. See the link in my sig.
     
    • Thanks Thanks x 1
  3. JLx14

    JLx14 L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    thanks ill give it a try

    *edit* thanks it works, but it still doesnt work for the water texture. i tied the surface of the water to the env_cubemap and i still has the purple and black texture.
     
    Last edited: Sep 27, 2009
  4. Dr. ROCKZO

    Dr. ROCKZO L8: Fancy Shmancy Member

    Messages:
    580
    Positive Ratings:
    159
    And here I was Cameron, thinking your Signature was probably very situational and never really used, and now I've seen it used twice in 2 weeks! That's 10 more times than mine ever gets used!
     
    • Thanks Thanks x 1
  5. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    145
    Hmmm.... What water texture are you using?

    :)
     
  6. Shadow Tyrant

    Shadow Tyrant L69: Deviant Member

    Messages:
    69
    Positive Ratings:
    3
    Wait, you tied it to an env_cubemap? Tied it? As in ctrl+T?
     
  7. JLx14

    JLx14 L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    oh i tied it to the surface with the eyedrop thing. i didnt tie it to a entity. going to try that later.
     
  8. psihomir

    psihomir L4: Comfortable Member

    Messages:
    192
    Positive Ratings:
    32
    I'm not sure, but I think you need to build the cubemaps one more time after setting mat_specular to 1 - the guide doesn't specify that. I might be wrong, but that's how I do it:

    mat_specular 0
    buildcubemaps
    mat_specular 1
    buildcubemaps
    retry
     
  9. Cameron:D

    Cameron:D L6: Sharp Member

    Messages:
    363
    Positive Ratings:
    145
    No. Doing that will just make a larger file (2 sets of cubemaps) and should have no difference on the outcome.
     
  10. Shadow Tyrant

    Shadow Tyrant L69: Deviant Member

    Messages:
    69
    Positive Ratings:
    3
    No, don't try that. That's a terrible, terrible idea. It's just that when you said "tie" I automatically assumed you mean ctrl+t, which would have been a large part of why you're having a problem.