[Help!] Map Crashes Server

Discussion in 'Mapping Questions & Discussion' started by Jazz, Nov 1, 2008.

  1. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    So here is what happens. Randomly before the setup phase ends in my map, it crashes any public server it is running. I am talking about my map pl_saloon. Here are some things I have done to combat the problem, but with no luck...

    1) Func_details. I put these babies everywhere to speed up the compile time, not sure if this is related to my map crash though.

    2) Fixed all bad geometry.

    3) Fixed all inputs and outputs.

    4) Checked interlopers and hammer for errors. The only problem I got was from hammer because I added a fourth cap to my payload map (so it is like badwater). The last cap does show up on the HUD and is fully functional when tested locally.

    5) Added info_observer_point's. I heard that not having any of these crashes servers, but since I added them nothing has really changed.

    6) I did the stress test described here. I am under the entity limit and I can't crash my game locally by doing the technique VP described.

    I attached my compile log if you would like to take a look at it, but I doubt you will find anything hammer or interlopers couldn't pick up. Ignore the "Warning: invalid neighbor connection on displacement near # # #" error, as I researched it and it is harmless.

    So, If anybody can think of something I am doing wrong and can help me, I would really REALLY appreciate it. Because I don't want to be unable to finish my contest entry and I think I have something good here. Also, if you REALLY want to look into this I could give you the .vmf. Just as long as you promise not to steal from it ;].
     
  2. zpqrei

    aa zpqrei Theme Changer Extraordinaire

    Messages:
    1,067
    Positive Ratings:
    1,122
    Maybe remove all the func_details, see if that works. I'm not really sure. I've never seen this problem before.

    -zpqrei.
     
  3. ChronoTriggerFan

    ChronoTriggerFan L7: Fancy Member

    Messages:
    435
    Positive Ratings:
    72
    Func details have nothing to do with it. removing them would only take his map an eternity to compile, they have never ever been seen to make a map crash. Though i would suggest asking mangy about it, he might have some theories back from when he was trying to make spywinder not crash.
     
  4. AKAfreaky

    AKAfreaky L1: Registered

    Messages:
    7
    Positive Ratings:
    2
    If it only happens in the setup stage, maybe it's an error with your team_round_timer entity.
     
  5. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    Here is my round timer set up. Nothing looks wrong to me.

    [​IMG]
     
  6. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    I believe I have narrowed down what is causing the crash. Whenever a player suicides the map crashes to the desktop. What causes this to happen?
     
  7. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    85
    there needs to be at least one info_observer_point.
     
  8. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    I have four.
     
  9. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    85
    k double check these settings

    start disabled - no
    team - any
    welcome point - no


    either that, or there's an error with the active spawn room, I would guess.
     
  10. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    So I can't have a welcome point?
     
  11. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    Ok, I changed all the cameras like you said and it still crashes. Here is how I manage to crash my game.

    1) First I explode myself in spawn after the setup time is done. Nothing happens except the usual stuff (respawn time, cameras work, etc.)

    2) Second, If I run outside and touch the cart and THEN explode, my game crashes.

    /me is stumped.
     
  12. MrAlBobo

    MrAlBobo L13: Stunning Member

    Messages:
    1,059
    Positive Ratings:
    219
    umm...perhaps its the cart then?
    try exploding without touching the cart
     
  13. Captain Planet

    Captain Planet L2: Junior Member

    Messages:
    63
    Positive Ratings:
    5
    mayby its the server setting??
     
  14. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    Everything works fine if I do not touch the cart and explode. If I push the cart for a few seconds and THEN explode, the game crashes.
     
  15. Jazz

    Jazz L5: Dapper Member

    Messages:
    240
    Positive Ratings:
    23
    Even if I touch the cart for a split second and suicide, I crash. I made a quick video to show you what happens.

    [ame="http://video.google.com/videoplay?docid=-3991635291671419108&hl=en"]Map crash, pl_saloon[/ame]
     
  16. l3eeron

    l3eeron L8: Fancy Shmancy Member

    Messages:
    594
    Positive Ratings:
    85
    I still think it's a camera thing...


    are all of them set to welcome point? I think one needs to not be welcome point.


    Does the same thing happen if there is another player on the map with you (even a bot)?
     
  17. Psyphil

    Psyphil L3: Member

    Messages:
    125
    Positive Ratings:
    30
    one should be welcome point, the others not.

    It surely looks exactly like when you have no observer_point in the map but that would be weird since it doesn't crash if you haven't pushed the cart.

    Here you say before the setup, has it changed or did u just write wrong? It is hard to push the cart before the setuptime has ended