Help, I'm off to a horrible start.

Discussion in 'Mapping Questions & Discussion' started by Nyne, Jun 21, 2012.

  1. Nyne

    Nyne L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    I thought it would be fun to start mapping. However, Hammer didn't open up without its share of problems. First being it only shows one window in the editor, however I see everyone else having four. I tried "Autosize 4 views", and that did nothing. Also, in the messages box, it says:

    File c:\program files (x86)\steam\steamapps\nyned\sourcesdk\bin\orangebox\bin\tf.fdg, line 1316: expected @
    File c:\program files (x86)\steam\steamapps\nyned\sourcesdk\bin\orangebox\bin\tf.fdg, line 1318: expected identifier after @
    File c:\program files (x86)\steam\steamapps\nyned\sourcesdk\bin\orangebox\bin\tf.fdg, line 1318: unrecognized section name @

    I don't even know what that means. I feel like the problems will be simple once someone points out what they are. If this is the wrong place to ask questions, well please point me in the direction of the right place.
     
  2. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    251
    Each view window has a little drop-down menu on the top left corner which appear as text indicating what setting the camera is at (e.g. 2D side). Click on that and you can change the view of each window. "Autosize 4 views" just makes all the windows the same size.

    The other problem you can ignore. It doesn't affect anything.
     
  3. Nyne

    Nyne L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    How do I get more windows to view with at once? I can change the one, but I can't have more than one.
     
  4. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    Like, so you have more than 4? You have to go into the options and set it so that your view-ports are set to Windows. then you can have as many as you'd like.
     
  5. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    251
    Oh sorry, I misread. My bad.

    Check if you can drag the edges of the window along; the other windows might just be hiding (they tend to do that). If you can't do that because there genuinely ARE no other windows, go to Tools > Options > General and untick "Use independent window configurations", click OK and restart Hammer. If it's already unticked, tick it and untick it. Then restart the program.
     
    • Thanks Thanks x 1
  6. Tarry H Sruman

    Tarry H Sruman Large Orphanage Proprietor

    Messages:
    871
    Positive Ratings:
    820
    Can you post a screenshot of what's happening please?
     
  7. Nyne

    Nyne L1: Registered

    Messages:
    5
    Positive Ratings:
    0
    Thanks Jeremy, that got the windows appearing. This can be locked or whatever needs to be done.
     
  8. henke37

    aa henke37

    Messages:
    1,927
    Positive Ratings:
    454
    Blame the message window error on Valve, they have a stray ] in their tf2.fgd file. Feel free to fix it yourself, it is easy.