Help a new guy out?

Discussion in 'Mapping Questions & Discussion' started by NameUser, Sep 15, 2011.

  1. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    Hi! I'm new to hammer, and being me I've managed to spend forever trying to figure out why it kept crashing on compile, only to realize I was doing something incredibly stupid. That's beside the point however.
    http://pastebin.com/7gzayGKA
    This is the error I get now. I'm compiling a simple map, no leaks, and I get that error. I can't seem to figure out. I see I am missing a skybox it appears, but as far as I know that is not a cause for the compile to fail. Anyways, any help would be really appreciated.
     
  2. Prestige

    aa Prestige im not gay anymore

    Messages:
    1,769
    Positive Ratings:
    1,517
    using the error checker (very useful), says:

    material "skybox/(null)rt" not found
    Description:
    The error is self-explanatory. Somewhere in your map you have referenced a texture that doesn't exist. Perhaps you used a texture from another modification or game you haven't correctly set your current game up for?

    Solution:
    Make sure you have your mod paths set up correctly and that you are including all mod contents you need.

    not really sure, never seen this error before.
     
  3. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    Should have expected as much. I have a bad habit of getting obscure errors noone's seen before. lol

    EDIT: Upon further experimentation, it appears I get this error with any map I compile. Ever since I downloaded tf2, I was missing a few various texture files. Could this be causing it? If so, how can I get the missing textures?
     
    Last edited: Sep 15, 2011
  4. zpqrei

    aa zpqrei Theme Changer Extraordinaire

    Messages:
    1,066
    Positive Ratings:
    1,122
  5. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,454
    Positive Ratings:
    234
    In case you're unsure of what he means by validate do this:

    Open steam>Games library.

    right click tf2 - open properties - look for the tab that says verify cash - run it - wait till the window does the auto close - don't close it even if the window says 100% done on the top of it (it's misleading I know - thanks Valve!) I've closed it a few times when it syas 100% done and it turns out it wasn't leading to other errors or the same error repeating itself.

    Once verified, start sdk, reset game configs and happy hammering.
     
  6. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    VBSP also seems to be crashing.
     
  7. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    Is there any reason you know of this would be happening?

    Edit: I verified my game cache. As it did last time I tried that, it didn't fix ANY of the missing textures.
     
    Last edited: Sep 16, 2011
  8. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    Nope. It just appears to stop running.

    Are you sure they're stock textures that are included with the game? Maybe they're just null textures.

    It also looks like it's your skybox texture. Can you go into your Map Properties and check that you have something entered for "Skybox Name"?
     
  9. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    Uhh... It's the resupply cabinet and the health/ammo packs. So yeah. lol

    Anyways "sky_day01_01" is what the skybox is set to. I left it at default since it's an indoor map.
     
  10. NameUser

    NameUser L1: Registered

    Messages:
    45
    Positive Ratings:
    1
    I hate to do this, but-
    BUMP

    Let me make the issue a bit more clear-
    Everytime I try to compile I get this error http://pastebin.com/7gzayGKA and vsbp crashes. I get the skybox null error and the vsbp crash no matter what map I compile, even one not made by me.
    I do beleive my missing textures are involved due to some recent experimenting I did with them, but I will be making a seperate topic for them for the issue with them is VERY odd.