HDR makes my map dark

Discussion in 'Mapping Questions & Discussion' started by Seitan, May 28, 2017.

  1. Seitan

    Seitan L3: Member

    Messages:
    136
    Positive Ratings:
    16
    I compiled my map with HDR lighting on, and also with a logic_auto and a env_tonemap with the following values:
    [​IMG]

    When I play the map with HDR on some parts of the map are really really dark and some are very bright, how can I fix this?
    [​IMG]
    This room is supposed to be properly lit
     
  2. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    937
    Positive Ratings:
    905
    Can you show the properties of the lights in different rooms? Lights can have seperate settings for HDR, so it may be that you messed around with those.
    Also, buildcubemaps and reload the game so that weapons don't look weird. If they still look weird, something's messed up.
     
  3. Seitan

    Seitan L3: Member

    Messages:
    136
    Positive Ratings:
    16
    I see that the brightness of the HDR lights is set to 1, I will try changing it
     
  4. Tumbolisu

    aa Tumbolisu  I ⌄ I 

    Messages:
    937
    Positive Ratings:
    905
    It will copy the normal settings if its set to "-1 -1 -1 1" so that can't be the problem, unless you changed the color.
    I also just noticed that your AutoExposureMin is bigger than the Max, maybe that is causing trouble? I doubt it though. Set Max to about 1.
     
  5. Seitan

    Seitan L3: Member

    Messages:
    136
    Positive Ratings:
    16
    I didn't knew anything about HDR so I colored the HDR lights with a different color but didn't check the brightness value, I set all of the HDR light values to -1 -1 -1 1 and it's compiling, let's hope it works
     
  6. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,217
    Yeah, the problem is almost definitely that your max exposure is only .5, less than the minimum. Maybe you meant to put 1.5?
     
  7. Seitan

    Seitan L3: Member

    Messages:
    136
    Positive Ratings:
    16
    I solved it, the HDR light value wasn't -1 -1 -1 1