Has something changed with the HUD?

Discussion in 'Mapping Questions & Discussion' started by Pianodan, May 9, 2010.

  1. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    I've made a map that we play on my clan's server called "Shooting Gallery." The map has a capture limit of 5, set using the point_servercommand entity tf_flag_caps_per_round 5 parameter. (Triggered via logic_auto)

    Now, this always worked just fine before, and it still works. However, the HUD is now saying we're playing to 3, where it used to say we were playing to 5. We still play to 5, it's just that the HUD is wrong.

    I haven't done any mapping since last summer and I haven't really been paying attention to updates. Has something changed that I need to fix?
     
  2. Flame

    aa Flame

    Messages:
    369
    Positive Ratings:
    433
    its a server command not a map command
     
  3. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    Yes, the number of caps is a server variable, but you CAN set the number of caps from the map. I have done so, using the method outlined above. When I designed the map last summer, the HUD reflected this change in the number of caps. Now it does not. Since I have not changed the map, I assume something has changed with TF2 in one of the updates. I am looking for suggestions as to what, and how to fix it so the HUD says "playing to 5" again.
     
  4. Lancey

    aa Lancey Currently On: ?????

    Messages:
    3,076
    Positive Ratings:
    1,314
    When are you running the point_servercommand?
     
  5. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    I'm triggering via logic_auto OnMapSpawn, and via Round_Timer OnRoundStart. The reason for the dual trigger is that at the END of each round, I'm setting it back to 3 so that the server doesn't continue to be set at 5 for the next map.
     
  6. Pianodan

    Pianodan L3: Member

    Messages:
    108
    Positive Ratings:
    16
    I'm bumping this, because I still can't figure it out. Why would "Playing to" in the HUD display "3", and the game itself play to 5?