Hammer won't Compile one of my Maps Anymore

Discussion in 'Mapping Questions & Discussion' started by Stu Pidface, Jul 10, 2015.

  1. Stu Pidface

    Stu Pidface L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Hello everyone, Yestarday I was working on my new map, cp_riverside, and for some reason the map will not compile anymore. I've tried restarting Hammer, restarting my PC and even checking over the changes I made to the map from my last successful compile. Nothing has seemed to help. Here is my most recent Compile log:

    HTML:
    ** Executing...
    ** Command: "G:\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "G:\Steam\steamapps\common\Team Fortress 2\tf" "E:\Users\Henry\Documents\MEGA\TF2 Maps\CP_Riverside\cp_riverside.vmf"
    
    Valve Software - vbsp.exe (Jul  2 2015)
    8 threads
    materialPath: G:\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading E:\Users\Henry\Documents\MEGA\TF2 Maps\CP_Riverside\cp_riverside.vmf
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    
    ** Executing...
    ** Command: "G:\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "G:\Steam\steamapps\common\Team Fortress 2\tf" "E:\Users\Henry\Documents\MEGA\TF2 Maps\CP_Riverside\cp_riverside"
    
    Valve Software - vvis.exe (Jul  2 2015)
    8 threads
    reading e:\users\henry\documents\mega\tf2 maps\cp_riverside\cp_riverside.bsp
    Error opening e:\users\henry\documents\mega\tf2 maps\cp_riverside\cp_riverside.bsp
    
    ** Executing...
    ** Command: "G:\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters:  -game "G:\Steam\steamapps\common\Team Fortress 2\tf" "E:\Users\Henry\Documents\MEGA\TF2 Maps\CP_Riverside\cp_riverside"
    
    Valve Software - vrad.exe SSE (Jul  2 2015)
    
          Valve Radiosity Simulator     
    8 threads
    [Reading texlights from 'lights.rad']
    [39 texlights parsed from 'lights.rad']
    
    Loading e:\users\henry\documents\mega\tf2 maps\cp_riverside\cp_riverside.bsp
    Error opening e:\users\henry\documents\mega\tf2 maps\cp_riverside\cp_riverside.bsp
    
    ** Executing...
    ** Command: Copy File
    ** Parameters: "E:\Users\Henry\Documents\MEGA\TF2 Maps\CP_Riverside\cp_riverside.bsp" "G:\Steam\steamapps\common\Team Fortress 2\tf\maps\cp_riverside.bsp"
    
    The command failed. Windows reported the error:
      "The system cannot find the file specified."
    
    Also I noticed instead of the proper .BSP file instead I have ended up with a .MDMP file which means that something isn't working correctly. I also tried compiling a different map just to check if the program stopped working but the other map compiled fine. Here is the link to the .MDMP Dump File. Thanks in advance everyone.
     
  2. Stu Pidface

    Stu Pidface L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Coming back to say I resolved the issue. I copied of the map and pasted it into a new file and now it works again.
     
  3. MoonFox

    MoonFox L10: Glamorous Member

    Messages:
    737
    Positive Ratings:
    72
    oh Koth_navajo and PL_snowed_in, DADDY IS COMING!
    (I had same issues)