Hammer turned my "almost a1 map" completely empty, I'd like some help.

Discussion in 'Mapping Questions & Discussion' started by ELEMES, Feb 9, 2019.

  1. ELEMES

    ELEMES L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Hey, I'm new here and I have stumbled upon something concerning

    Yesterday I was working on my map: koth_billabong, its all good, the map is almost viable to be played upon. I was making most my brushes into func_detail after watching ueak_crash's guide about it.

    Then when I opened the file today. Poof, completely empty, not a brush or an entity in sight as if I haven't touched a thing since creating the file itself.

    I looked into it and apparently you should always say no to the pop up "hammer didnt shut down correctly, load last auto save?" and load it manual. Which i didn't and used this feature quite often. both my original and autosave file is empty.

    Also as a side note, few days before, my tf2 mysteriously "uninstalled" itself despite still having the game file, i just cant open it on steam because it says I need to install it. I can still run the map and all in hammer until this happened. Is this related?

    I messed around and tried to open the bsp file out of desperation, I literally have no clue what to do.
    (My computer is pretty much garbage, Windows 7. Im literally waiting for my newly ordered laptop to arrive in 1-2weeks.)

    The file size is 652KB so I think the data is still in there and I just hope that I can restore it. It would be a reeeal pain in the neck to make it from scratch.

    All help would be greatly appreciated, Thankyou in advance.
     
  2. ELEMES

    ELEMES L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Update, I loaded the seemingly empty map and it loaded like nothing happened, everything is there. But still the hammer shows that it is empty. This is some sort of visual problem
     
  3. Wyvern

    aa Wyvern Certified TF2 Cartographer

    Messages:
    104
    Positive Ratings:
    144
    My best guess is that hammer has moved the camera off into the void. If this is so, you can manually move the camera via the grid. Select the :cameratool: button, and locate a small, turquoise circle on the grid.
    Capture70.PNG
    Then, you can just click and drag it onto your map. I hope this helps!
     
  4. Narpas

    aa Narpas Takes way to long to make and update maps

    Messages:
    417
    Positive Ratings:
    399
    You could've also hidden everything. Try pressing "U" to unhide everything, or check the right of the screen and make sure all the visgroups are checked on. Also check to make sure that your 3D camera is set to Textured or something similar
     
  5. ELEMES

    ELEMES L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Here are two pictures, one in the hammer editor, in the coordinates 0,0,0. And the second picture is when I load the map. The map name is correct, and I know I added the control point in coordinates 0,0,0 or VERY close to it. Hope it makes my problem clearer. I tried all your suggestions but doesnt seem to fix it. hammer problem.PNG 20190210144645_1.jpg
     
  6. ELEMES

    ELEMES L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    Its not a true fix but I copied the bsp file and decompiled it with BSPSource decompiler. Some brushes have wrong textures and the info_player_teamspawn model went to the green freenman model instead of the engi but I'll take it
     
  7. ics

    aa ics http://ics-base.net

    Messages:
    814
    Positive Ratings:
    513
    You propably did a bad brush during func_detailing or something. When you opened hammer, before it went blank, did it ask about something about solid being removed or similar? If you licked yes, it might have corrupted the map. Same thing happens occasionally when you start hammer after crash and it asks do you want to load the previous. Always click no, and open manually. You can verify the corruption by opening the vmf with any text editor. If there are only few lines, the map is gone permanently.

    For future reference, i suggest keeping several copies of the level, like saving at times with a different name. This way if you lose one, you can always go back. Decompiles arent exactly a good idea to go back since as you noticed, things arent always like you assume. Plus the brushwork might go really bad in decompile ( off grid) and fixing that is tiresome.
     
    • Thanks Thanks x 1
  8. FloofCollie

    aa FloofCollie I really suck!

    Messages:
    541
    Positive Ratings:
    463
    Oh, you encountered it too. Trust Hammer to have an easy quick-loading option that has a chance of obliterating all your work.
     
    • Funny Funny x 2
    • Like Like x 1
Tags: