Hammer spasm?

Discussion in 'Mapping Questions & Discussion' started by Bull, Mar 17, 2015.

  1. Bull

    Bull L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    140
    So my Hammer seems to go bonkers somehow. Not really sure what I did but when I move the mouse around in the 3d view, all sort of disfigured up 3d brushes spam my screen suddenly.

    What is going on?

    send help

    Evidence
     
  2. Crash

    aa Crash func_nerd

    Messages:
    3,074
    Positive Ratings:
    4,563
    That kind of feels like a video card issue to me, but I could be mistaken. I just know I would get similar artifacts in game with my old video card that was starting to go.
     
  3. Bull

    Bull L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    140
    My card's quite new actually - Nvidea Geforce GTX 780... should be able to render Hammer normally I'd hope.
     
  4. Vel0city

    aa Vel0city personal pick-pocketing parrot

    Messages:
    1,883
    Positive Ratings:
    1,488
    Validated TF2's cache?
    Up-to-date video drivers?
    Weird Hammer settings?
     
  5. UKCS-Alias

    aa UKCS-Alias Mann vs Machine... or... Mapper vs Meta?

    Messages:
    1,264
    Positive Ratings:
    748
    Never trust hammer. There can be some odd things rendering wise in hammer. A few thigns i can imagine:
    - Did you run hammer for a long time in a row without restarting? If so, a restart often can do good.
    - Is there a corrupt brush?
    - How much does your map contain? More brushes gives more visual errors. I often have that many brushes just dissapear and i have to move the camera or used the cordon tool to render it properly again.
    - How high your RAM usage? I see steam possibly downloading something that could cause I/O issues for hammer.
     
  6. Bull

    Bull L4: Comfortable Member

    Messages:
    178
    Positive Ratings:
    140
    Just did, no problems validating.
    Drivers are brand new!
    I did not change my hammer settings at all, this is my first project that has these spasms. :(

    It unfortunally happens with every time I launch the map. I can still fly around and map normally but when I look at a centain angle in the 3d view, brushes start to crash all over the place. Move the cam back, they're normal. It's not game-breaking but it's quite annoying.

    Might be a corrupt brush somewhere... I can still compile my map normally though, without crashing.

    Map contains quite some brushes, but not nearly more than my previous projects that did not have these problems.

    Hammer uses about 1GB of RAM offa my 16GB total. Should be fine?
     
  7. Vel0city

    aa Vel0city personal pick-pocketing parrot

    Messages:
    1,883
    Positive Ratings:
    1,488
    Oh this isn't new. I have the same issue with overlays flickering and even completely vanishing when looked at from certain angles.

    Yes, I am in non-shaded mode.