[Hammer] Shortcuts issues

Discussion in 'Mapping Questions & Discussion' started by moroes, Aug 18, 2010.

  1. moroes

    moroes L1: Registered

    Messages:
    31
    Positive Ratings:
    7
    Hi all,

    I met a new problem since a few days now...I thought it will disappear after a reboot but unfortunately the problem stay here. So I searched about a solution but there was nothing about that.

    SO I hope I'll find someone here which he had this problem before and if not, some paths to find a solution.

    The problem is very simple but very boring ; my shortcuts in Hammer are very very very slow...it doesn't works well.

    For example (to help you to understand) :

    I'm in my map and I would like copy/paste a model in the 3D View.
    To make that simple action, I have to click many times the shortcut on my keyboard to make this simple action works...


    This is an example...it makes the same thing for all of my shortcuts IN Hammer (CTRL + S / SHIFT + Z / CTRL + A / etc / etc / ...) :bored:

    So...anyone met this problem before? Anyone could help me on that?

    A last precision ; my keyboard works very well in other applications and I'm working on Windows Seven 64b.

    Thanks in advance,
     
  2. J4CK8

    J4CK8 L11: Posh Member

    Messages:
    820
    Positive Ratings:
    223
    I think I know what you mean. Basicly ctrl doesn't work very well in hammer? I find myself with this problem, incredibly annoying. I usualy have to repeat any process at least twice that involves ctrl, and I end up getting frustraited after it happens so many times and find myself bashing ctrl, yet the ctrl key works perfectly normal outside of hammer.
     
  3. moroes

    moroes L1: Registered

    Messages:
    31
    Positive Ratings:
    7
    Yes, you're right (you have a better vocabulary than me so it's better for understanding the problem :D) ! That's my problem but you can add "SHIFT" :(
     
  4. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    I've been having this problem too, and I think Muffin has as well. It's not yours or your system's fault, it's just Hammer being poopy.
     
  5. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,467
    Valve broke it a while back which I believe was around the time they updated the SDK to be split up into 3 engines.
     
  6. moroes

    moroes L1: Registered

    Messages:
    31
    Positive Ratings:
    7
    Arf...so, no solution at short time? :/ We have to wait a "patch" :/

    Thanks.

    PS : Any contacts with Valve here? (I can hope ^^ )
     
    Last edited: Aug 19, 2010
  7. Exist

    Exist L6: Sharp Member

    Messages:
    306
    Positive Ratings:
    112
    OS?

    Just wondering, is everyone here using Vista/Win7? I don't get this issue at all on XP.

    Or maybe it's Microsoft's keyboard drivers? If it gets annoying, maybe try rolling back the drivers...
     
  8. moroes

    moroes L1: Registered

    Messages:
    31
    Positive Ratings:
    7
    A friend which is using Windows XP don't meet this kind of problem (as you) ...
     
  9. J4CK8

    J4CK8 L11: Posh Member

    Messages:
    820
    Positive Ratings:
    223
    I'm on XP. I might try rolling back the driver later. It's almost as annoying as when my wireless keyboard runs out of batteries and I get confused, thinking I've got stuck somewhere or the game crashed. I need to go back to wired.
     
  10. moroes

    moroes L1: Registered

    Messages:
    31
    Positive Ratings:
    7
    Well in waiting a correction I extracted all the materials and models from TF2 in L4D so I can work on the map with a good Hammer ^^