Hammer Problems

Discussion in 'Mapping Questions & Discussion' started by d4rk, Nov 14, 2013.

  1. d4rk

    d4rk L1: Registered

    Messages:
    16
    Positive Ratings:
    2
    Ive been having trouble with sdk/hammer lately. My hammer used to be fine with the bypass around steampipe but lately errors have been coming up and if they dont come up, when i open up a map all the windows are black and behave very strangely.

    [​IMG]
    errors that sometimes come up when opening maps


    [​IMG]
    what it looks like on a blank map


    [​IMG]
    what it looks like when i open up my map

    if someone could give me a run down of how their files and folders are setup that would be awesome. Oh and also i cannot run hammer from any source engine except MP.
     
  2. hazzmando

    hazzmando L1: Registered

    Messages:
    4
    Positive Ratings:
    7
    I've been looking for a fix to this, as well, since yesterday, when it first happened. Unfortunately I haven't found a fix yet.

    Also, in my hammer, if I try to load a map it crashes and closes.

    Please tell me if you find a fix.

    EDIT: I found a fix, kinda...
    My hammer works perfectly fine if I run straight out of the 'Team Fortress 2\bin', however it still has the afore mentioned problems if I run it out of the sdk in steam's tools library.

    Hope this helps...
     
    Last edited: Nov 15, 2013
  3. FiLi

    FiLi L4: Comfortable Member

    Messages:
    195
    Positive Ratings:
    50
    The first thing to always check is that your ABS Resource Pack is updated. I know my game was crashing on loading more developed maps, but after I updated the pack it was fine. Not sure about those other problems at the moment, but I'm sure someone will be able to better help you soon.