Hammer not compiling my maps.

Discussion in 'Mapping Questions & Discussion' started by Rogueleader, Mar 1, 2008.

  1. Rogueleader

    Rogueleader L1: Registered

    Messages:
    13
    Positive Ratings:
    0
    Ok so this may sound like i have no idea what I'm doing but trust me i do know what is going on.

    So when i try to re-compile one of my maps, after making changes, it compiles. But when i load it up in game nothing has changed its all the same.

    Then i tried to copy and past the map into a new window and compile it from there. But it does this:
    Then i restarted steam and it still came up with the same error on the new file. I compiled once more on my updated file but it didn't compile any of the changes.

    I don't know why hammer wont compile my map.
     
  2. Scotland Tom

    Scotland Tom L6: Sharp Member

    Messages:
    332
    Positive Ratings:
    64
    Your "Error opening..." problems simply stem from the first error you posted. "Entity 262: func_areaportal can only be a single brush" That error means exactly what it says it means. You've got a func_areaportal that you've tried to make into 2 brushes instead of one. You need to find that areaportal (entity 262) and recreate it as a single brush. So long as you don't have any other errors, my guess is that should solve your problem.
     
  3. Rogueleader

    Rogueleader L1: Registered

    Messages:
    13
    Positive Ratings:
    0
    alright
     
  4. Rogueleader

    Rogueleader L1: Registered

    Messages:
    13
    Positive Ratings:
    0
    well that did solve my problem and i thank you for that.