Hammer issue

Discussion in 'Mapping Questions & Discussion' started by Buckwheet, Aug 6, 2009.

  1. Buckwheet

    Buckwheet L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Howdy howdy, I just started working with Hammer today after a long while (4ish years) and as I watched tuts on youtube I started mashing buttons like a chimp and now no matter what tool I have selected (camera, entity, block) they all act like camera in each of the four screens.

    The block tool won't let me make blocks (like I did 10 minutes prior). WHen I click and drag the 2d view moves, as if I'm dragging the grid.

    The entity tool won't spawn entities.

    Select tool won't select the box I made before the issue.

    I was hitting ctrl + w or e, trying to get the camera centered on something, then everyone thing wonko.


    A bunch of nanners and a tasty beverage for the Solver. :woot:
     
    Last edited: Aug 6, 2009
  2. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    restart your comp only way to make it work again.
     
  3. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Restarting Hammer is always a good idea when something goes weird.
    Having regular saves is also a good idea ;)
     
  4. Buckwheet

    Buckwheet L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Alrighty, thanks guys.

    Tasty beverages all around! :p
     
  5. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    Only problem is restarting only hammer or even steam wont fix it.