Hammer is crashing, a lot...

Discussion in 'Mapping Questions & Discussion' started by Foot, Sep 13, 2016.

  1. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    So, when I was working on my koth map I placed a few overlays.

    When I place overlays/decals hammer will just crash for no reason, but in the past it stopped when it crashed and it would require me to place an overlay again to make it crash.

    But now after i placed a bunch of patch overlays under my health packs it started crashing every few minutes and i have removed them, reinstalled (and wiped all custom content) tf2 several times and started on an entirely new map and its still happening.

    It is impossible for me to progress in any map because of this constant crashing.
    I even open decompiled valve maps and it still happens after messing around for a few minutes.

    Please reply with anything that could help me.
    Thanks.
     
  2. The Letter Before A

    The Letter Before A Cool Idiot

    Messages:
    300
    Positive Ratings:
    118
    if you don't already make ctrl-s ing a twitch everytime you do any action
    Hammer crashes a lot
     
    • Like Like x 1
  3. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    Ok.
    But in the past and when i see my friends using hammer and even in ueakcrash's videos, they almost never crash on any maps.

    I guess i will just try and find a virus of some kind.
     
  4. MaccyF

    aa MaccyF Notoriously Unreliable

    Messages:
    900
    Positive Ratings:
    1,443
    what does task manager show when using hammer? (usage percentages etc.), it might be a hardware thing.
     
  5. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    So it says hammer is using 400~ mbs of ram with gravel pit open and up to 10% of my cpu.(4790k)
     
  6. MaccyF

    aa MaccyF Notoriously Unreliable

    Messages:
    900
    Positive Ratings:
    1,443
    sounds pretty normal to me tbh, i'm not sure what could be causing the extensive crashing other than hammer's ~20 year old software fuckery
     
  7. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    idk either, it's crashed 3 times in the last 10 minutes on a dev textured control point layout.

    Could steamcloud effect it at all?
     
  8. MaccyF

    aa MaccyF Notoriously Unreliable

    Messages:
    900
    Positive Ratings:
    1,443
  9. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    Yea, I have several times.
     
  10. ibex

    aa ibex

    Messages:
    253
    Positive Ratings:
    350
    Is it specific to the vmf? ie crashing when you edit that specific vmf
     
  11. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    Nope, It happens on all vmf files.

    So far I have tried using the cs:go sdk and it crashes on launch.
    I may try the gmod hammer to see if its just tf2.
     
  12. Pocket

    aa Pocket func_croc

    Messages:
    4,479
    Positive Ratings:
    2,209
    Maybe your graphics driver is borked in ways that only affect this program. Could just be one of those things where this particular one-in-a-million combination of hardware, drivers, and app just plain doesn't work and the only thing you can do is move to a different hardware setup.
     
  13. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    bump
     
  14. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,454
    Positive Ratings:
    234
    hammer was crashing every 30 secs for me a coupe od days ago - look for invalied stucture alt+P get rid of it and any dispalcements that have an entity attached to them
     
  15. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    it happens on any map (with any displacements or not.)

    EDIT: it does not crash when im not moving the camera or placing things
     
    Last edited: Sep 21, 2016
  16. Foot

    Foot L2: Junior Member

    Messages:
    65
    Positive Ratings:
    14
    I fixed it.
    I had to wipe my pc.

    Thanks for the help anyways.