Hammer Help Please

Discussion in 'Mapping Questions & Discussion' started by SparkyShock, Feb 13, 2016.

  1. SparkyShock

    SparkyShock L3: Member

    Messages:
    125
    Positive Ratings:
    13
    Ok, without me changing anything with spawns, half of my map wont load and blue spawns at red even though the blue spawns are in the vmf. I didn't change anything and i dont know what to do.
     
  2. Gabe Noodle from Volvo

    Gabe Noodle from Volvo L3: Member

    Messages:
    142
    Positive Ratings:
    32
    I don't know why the map isn't loading, try checking your compile log here (http://www.interlopers.net/errors/), but for the spawns, check that you set them to the correct team, if both teams spawn at the same place, they're probably set as team "any".
     
  3. zahndah

    aa zahndah professional letter

    Messages:
    718
    Positive Ratings:
    627
    Have you turned on the cordon tool or radius culling?

    Check the row of buttons at the top for :cordonenable: or a button that looks like an R in a red circle. then them off if they are on as they limit the part of the map which is loaded.
     
  4. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,381
    Positive Ratings:
    4,210
    It's likely that the compile is failing for one reason or another, so it's not updating. Check the map for invalid solids or other errors by pressing Alt+P.
     
  5. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,429
    Positive Ratings:
    1,173
    Entity displacements are often causing not updating map. They are not shown in errors list but they don't let BSP finish its work.
    Also, displacements with tool textures (nodraw too) behave themselves the same.
     
  6. Vel0city

    aa Vel0city func_fish

    Messages:
    1,909
    Positive Ratings:
    1,530
    *insert buzzer sound here* Wrong, entities on displacements do show up in the compile log as an error, as do displacements covered in tool textures.
     
  7. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,429
    Positive Ratings:
    1,173
    http://imgur.com/3y0DIGu
     
  8. Vel0city

    aa Vel0city func_fish

    Messages:
    1,909
    Positive Ratings:
    1,530
  9. Crowbar

    aa Crowbar perfektoberfest

    Messages:
    1,429
    Positive Ratings:
    1,173
    k. I also noticed that it will compile it first time.
     
  10. SparkyShock

    SparkyShock L3: Member

    Messages:
    125
    Positive Ratings:
    13
    that seemed to fix it, i normally have the red circle on and it never happened. Maybe Valve should find a way to update hammer.
     
  11. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    Good joke :3
     
    • Agree Agree x 2
  12. Gabe Noodle from Volvo

    Gabe Noodle from Volvo L3: Member

    Messages:
    142
    Positive Ratings:
    32
    Well there's this http://sledge-editor.com/
     
  13. Vel0city

    aa Vel0city func_fish

    Messages:
    1,909
    Positive Ratings:
    1,530
    Ok now that is interesting to see. Will check that out.
     
  14. Muddy

    Server Staff Muddy Muddy

    Messages:
    2,381
    Positive Ratings:
    4,210
    Last I checked, Sledge was only compatible with GoldSrc. Unless they added Source support since then?
     
  15. Vel0city

    aa Vel0city func_fish

    Messages:
    1,909
    Positive Ratings:
    1,530
    Well they say it right on the site, currently it's only GoldSrc. Source support will be added later.

    From the site:

     
    • Thanks Thanks x 1
  16. Gabe Noodle from Volvo

    Gabe Noodle from Volvo L3: Member

    Messages:
    142
    Positive Ratings:
    32
    You can still map for source if you configure it properly, it's just not fully supported so pieces are missing. For example displacement just don't work properly, but you can still compile .bsp files somehow.
     
    • Thanks Thanks x 1