Hammer grid changed again...

Discussion in 'Mapping Questions & Discussion' started by Dutchsilab, Oct 24, 2012.

  1. Dutchsilab

    Dutchsilab L1: Registered

    Messages:
    29
    Positive Ratings:
    1
    Hello,

    Today suddenly my Grid changed again in Hammer, Its quiet annoying because it happend several times already.

    Here below a better view of the problem is explained;
    (Cant drag the line to the right one.)
    [​IMG]

    (And here the line skips the line where it supposed to be attachted on.)
    [​IMG]

    I cant drag the lines to each other because the grid is different or something, I already tried to change the grid, Applying "Snap to grid" and then restart Hammer, but after several failures of trying that didn't work aswell.


    Anyway, I hope someone can help me with this issue.

    Thanks for reading.
    Daedalus
     
  2. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,573
    Use [ or ] to change the grid size. If it's not snapping, drag the vertice out further until it snaps to something and then drag it back. If it's not snapping it's because you've selected two vertices and only one of them is snapping whilst the other is locked into the selection. You can snap them to the grid individually through the camera view.

    That or your brushes are invalid and keep getting "fixed" automatically by Hammer.
     
  3. Kill_the_Bug

    Kill_the_Bug L14: Epic Member

    Messages:
    1,477
    Positive Ratings:
    240
    If you leave Snap on and copy paste something frm another map file - will it auto align to the new grid? Sorry I'm at work and If I didn't ask it now I'd never remember by the time I get home.
     
  4. Dutchsilab

    Dutchsilab L1: Registered

    Messages:
    29
    Positive Ratings:
    1
    Thanks for the response's

    I will try it.
     
  5. Dutchsilab

    Dutchsilab L1: Registered

    Messages:
    29
    Positive Ratings:
    1
    Tried copying something from an other map, Same result.
     
    • Thanks Thanks x 1
  6. Ravidge

    aa Ravidge Grand Vizier

    Messages:
    1,544
    Positive Ratings:
    2,495
    How small are these things/points, it looks like you've zoomed in quite a bit?

    It's pretty common for verticies at these tiny sizes bug out when forced into odd angles, and or off-grid positions.
    I would encourage you to never go below grid size 4, when doing TF2 mapping. There are a few exceptions, but as a nice rule of thumb, 4 is the lowest you'll need to go.

    If nothing else works, recreate the brushes from scratch, and be more careful.
     
  7. Dutchsilab

    Dutchsilab L1: Registered

    Messages:
    29
    Positive Ratings:
    1
    Thanks for your reply,

    I zoomed in because otherwise you couldn't see the exact problem,
    The 2 lines are just 2 blocks and normally they just merge with eachother, But as you can see they don't do that now. I will take a look on the Grid settings.
     
  8. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    Just wondering, how did you create these brushes? Manually, by Cut, by Carve?
     
  9. Spacek531

    Spacek531 L4: Comfortable Member

    Messages:
    162
    Positive Ratings:
    60
    Try pressing ctrl+W, that toggles the snap-to-grid function.

    That is, if you haven't tried it already.
     
  10. Burnout6010

    Burnout6010 L5: Dapper Member

    Messages:
    207
    Positive Ratings:
    23
    Try Shift+W, just had this issue and fixed it quick 'n easy with this