Hammer editor view cropped to the side

Discussion in 'Mapping Questions & Discussion' started by Joeakuaku, Nov 1, 2014.

  1. Joeakuaku

    Joeakuaku L1: Registered

    Messages:
    15
    Positive Ratings:
    2
    As the title implies, I'm having trouble with using Hammer. The 3d viewport (ugh, I haven't used it in a while, pardon me if my vocab is rusty) is cropped and tilted to the top left corner. Below is a screenshot.

    https://www.anonimg.com/img/38b73996b5420cae9d1484096bf8c9e5.png

    I should mention that when I click it flashes to the normal view for a frame or two. This is really bugging me since it doesn't affect the placement of things, only my view. It's also like this in SFM, too.
     
    Last edited: Nov 1, 2014
  2. wareya

    wareya L7: Fancy Member

    Messages:
    493
    Positive Ratings:
    173
    Well, this is weird. Maybe try disabling steam overlay or changing random 3d view settings in hammer.
     
  3. Joeakuaku

    Joeakuaku L1: Registered

    Messages:
    15
    Positive Ratings:
    2
    It fixed itself for a bit, but it's happening again. New info: if I have more than one viewport set to 3d, then it's reversed. It looks normal except when moving or generally updating the view.
     
  4. Joeakuaku

    Joeakuaku L1: Registered

    Messages:
    15
    Positive Ratings:
    2
    Nevermind. It was caused by Razer Game Booster. I closed it and it fixed it.
     
    • Thanks Thanks x 2
  5. nightwatch

    aa nightwatch

    Messages:
    640
    Positive Ratings:
    446
    Thanked for posting the solution, even if no one ever has the problem for the same reason.
     
  6. takabuschik

    aa takabuschik

    Messages:
    663
    Positive Ratings:
    316
    ctrl+a resizes every window to it's original size, might be worth a try to see if it also places everything back in place.