hammer editor buggy camera and grid ( need some help !)

Discussion in 'Mapping Questions & Discussion' started by malik, Jul 9, 2014.

  1. malik

    malik L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    hello ,
    i got some problems when i started the hammer editor once:
    the problem is with the 3d view camera , and the grid view. :thumbdown:

    [​IMG]

    [​IMG]

    [​IMG]

    i need some help with these problems , cant do anything with it! my hammer editor was pretty fine until i open it once and i found it like that :blink:
     
  2. Fr0Z3nR

    aa Fr0Z3nR Creator of blackholes & memes. Destroyer of forums

    Messages:
    6,391
    Positive Ratings:
    4,906
    Could you be more specific as to what the issue is. Maybe I'm missing something very obvious.
     
  3. shadowslasher11

    aa shadowslasher11

    Messages:
    392
    Positive Ratings:
    326
    EDIT: Or do you mean the grid space? That's just as far as it goes...
     
    Last edited: Jul 9, 2014
  4. malik

    malik L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    as i said , the problems is with the view ports :
    1) in the 3d view port , every thing is Diagonal , the camera moving ( for example : when you press w to move the camera straight , the camera goes compleatly wrong way )

    2) in the grid view port, when you zoom in and out , the grid doesnt zoom well , as i present in the pic

    im not using the sdk for the first time , i used it and it worked pretty well before , i dont know what happend :confused:
     
    Last edited: Jul 9, 2014
  5. malik

    malik L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    by the way , i tried to reinstall editor , reset the sittings, but the problem still in the editor :/
     
  6. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    393
    There is nothing in your screenshots that indicate a problem with Hammer. The grid ending is normal, that always happens if you zoom out far enough.

    The only potential issue I see is that your map is extremely large.. it looks like it's 9000 units square which is an absurd scale.
     
  7. malik

    malik L1: Registered

    Messages:
    4
    Positive Ratings:
    0
    it seems i really didnt explained the problem well .....
    i dont know how preview it but all what i can say that the 3d view camera is going so wrong , the blocks , the camera movement , all of that goes Diagonal .

    maybe i should upload a video ? to represent the problem ?
    here is my new pic . i hope it will give the clue

    [​IMG]
     
  8. Mick-a-nator

    aa Mick-a-nator

    Messages:
    640
    Positive Ratings:
    314
    That looks like the 3D viewport is rendering only a small portion of the camera's view. That kind of skewing happens at the edges of 3D render views and is related to FOV, among other things. Not sure why Hammer would do this though.
    Try changing the viewport size and using the camera tool. Open up your settings too (Tools -> Options -> 3D views). There's not much to change, but the FOV goes right down to 30! Some weird stuff might be happening down there. You may want to change some settings while you're there anyway, like model render distance and camera speed.
    I have no idea if any of that will help, but I'll keep looking.
     
  9. henke37

    aa henke37

    Messages:
    1,927
    Positive Ratings:
    454
    You have rotated the 3d viewport camera. Unrotate it. Hold space and right mouse button drag.
     
  10. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,745
    That's even possible?? o_O
     
  11. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    393
    Don't think so, I tried it and it just pans the camera around. To use the airplane term, I'm not sure Hammer has the ability to roll the camera.

    Maybe it's stored in a value in a config file somewhere but I don't think there's a way to do it in the app itself.