Hammer doesn't work

Discussion in 'Mapping Questions & Discussion' started by Veltha, Jan 10, 2016.

  1. Veltha

    Veltha L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Hi again guys. Today I was goin to continue with my map, but when i try to open Hammer, this appears:

    Hammer Error

    D:\Steam \ SteamApps \ Common \ Team Fortress 2 \ hl2 \ gameinfo.txtt is missing.




    Any ideas on how can I fix this?
     
  2. MoonFox

    MoonFox L10: Glamorous Member

    Messages:
    737
    Positive Ratings:
    72
    strange... check cache first, then come back... sounds like cache bug
     
  3. Vel0city

    aa Vel0city func_fish

    Messages:
    1,931
    Positive Ratings:
    1,540
    Looks like you have the wrong gameinfo.txt text file selected. TF2's default gameinfo.txt is in the tf folder, not in Team Fortress 2\HL2. But do indeed validate TF2's cache by right-clicking Team Fortress 2 in your Steam Library, then Properties>Local Files>Verify integrity of game cache. This might fix it.

    also 666 messages m8
     
  4. MoonFox

    MoonFox L10: Glamorous Member

    Messages:
    737
    Positive Ratings:
    72
    you have a mission: cure the evil of the world, do not reply
     
  5. Veltha

    Veltha L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Well, I already cheked the cache before I even posted this, but i'm going to try again, hope it works...
     
  6. Veltha

    Veltha L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    I've already check the cache again, and still not work... guess I'm fuck...
     
  7. 404-universe

    404-universe L1: Registered

    Messages:
    12
    Positive Ratings:
    2
    You might have to force it to redownload hammer et. al. Rename /bin to something else (/bin-backup for example) and then try verifying your game cache.
     
  8. Veltha

    Veltha L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    Wait, so i have to redownload the game?
     
  9. Veltha

    Veltha L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    I don't know if this fix the problem completely, but at least it's working for now: I just copy the gameinfo.txt from the tf folder and pasted it into the hl2 folder
     
  10. 404-universe

    404-universe L1: Registered

    Messages:
    12
    Positive Ratings:
    2
    Does hammer work?
     
  11. 404-universe

    404-universe L1: Registered

    Messages:
    12
    Positive Ratings:
    2
    Just as a thought - if you go to options (under tools), what are your settings?

    Mine look like this:
    [​IMG]
     
  12. Hotel Detective

    Hotel Detective L4: Comfortable Member

    Messages:
    187
    Positive Ratings:
    189
    Are you running Hammer through Source SDK or through Hammer.exe in the bin folder?

    Cause I get that error when running it from Source SDK
     
  13. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    Yeah, if pasting the file into Half-Life 2 fixed the problem, you're probably launching Hammer from the wrong place or had it set up to use the wrong configuration. You may have accidentally launched the BAT file and picked Half-Life 2 from the dropdown list, and it memorized that setting? Because I've noticed that after I launched the BAT file instead of the EXE, it stopped popping up that list anymore even if I switched to launching the EXE.
     
  14. Veltha

    Veltha L1: Registered

    Messages:
    10
    Positive Ratings:
    0


    Well, it kinda fix the problem, since now I have another issue: instead of having the normal textures in the texture browser, there's weird images (I don't even think they're textures) from cosmetics and items from the game (Like keys and hats), and images from the achievements, and when I click on the "Browse" button Hammer immediately crash.



    Captura.PNG

    As you can see in the image, those are my configs. I notice that your configs are different from mine. For example, in Game Directory I have:
    Team fortress 2\HL2
    And you have:
    Team Fortress 2\tf

    Also, look at the texture browser...
     
  15. Veltha

    Veltha L1: Registered

    Messages:
    10
    Positive Ratings:
    0
    I think I finally fix the problem, for some reason, the config set to Half Life 2, instead of Team Fortress 2 :D
    Thanks for the help anyways guys, I really appreciate.