Hammer & 64bit Windows7

Discussion in 'Mapping Questions & Discussion' started by bakentake, Jun 28, 2009.

  1. bakentake

    bakentake L1: Registered

    Messages:
    26
    Positive Ratings:
    12
    I've filled out support for this and they just told me to look on their forums. I was hoping somebody here has ran into this problem before.

    http://forums.steampowered.com/forums/showthread.php?t=907575

    The topic I made there. Hopefully I can get a faster reply here. Or atleast some suggestions on how I could change where its looking. I've already reinstalled the SDK, and looked around in the files but I couldn't find anything.

    Maybe somebody here can/has ran into this problem.

    Thanks.
     
  2. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,468
    Open up Hammer and go to Tools > Options where you will be able to set where Gameinfo.txt is located. :)
     
  3. bakentake

    bakentake L1: Registered

    Messages:
    26
    Positive Ratings:
    12
    Well I can open up the Source SDK which lets you launch hammer; but when I try to launch hammer I get the error.

    Source SDK being the window that has

    Applications
    Hammer Editor
    Model Viewer
    Face Poser
    Documentation
    Release notes
    SDK Reference Docs

    Etc.

    Is there another way to launch hammer?
     
  4. MaGicBush

    MaGicBush L2: Junior Member

    Messages:
    56
    Positive Ratings:
    1
    Make sure you run TF2 once before trying to use Hammer, I had a similar problem when I first installed(also running Vista Ultimate 64bit). I have everything installed in the default x86 directory and have had no other issues really(other than the last update). Make sure you turn off DEP and UAC as well, they just cause issues and don't help much with security honestly.

    Also you didn't download as a bit torrent right? This seems to be a common issue for those who downloaded HL2(google search brought up a lot)..

    *edit*

    Just realized the 7 at the end of Windows on your subject lol, so DEP and UAC may not apply(have not used Windows7 yet, and havn't had the training at work yet).
     
    Last edited: Jun 28, 2009
  5. DJive

    aa DJive Cake or Death?

    Messages:
    1,466
    Positive Ratings:
    736
    I'm tnot to sure the problem sadly, however i too use Win7 64Bit and have no problems =(
     
  6. bakentake

    bakentake L1: Registered

    Messages:
    26
    Positive Ratings:
    12
    Well I downloaded steam, then copied all my old game files into the steam folder on the new computer, but after reinstalling Source SDK I can't imagine its because of a setting leftover from the old computer.

    What is the "-game parameter" and "VCONFIG"? I'm assuming theres a text file somewhere in the SDK that tells it where to look for the game info.txt

    I only reinstalled Source SDK, not the Base or Base - Orange Box. What relation do they have as far as hammer goes? I suppose they could be directing it to the wrong program files folder.
     
  7. MaGicBush

    MaGicBush L2: Junior Member

    Messages:
    56
    Positive Ratings:
    1
    Aye, most likely culprit. Plus you have registry keys, etc that don't get put in if you just copy/paste files over. You just need to delete(keep saved game files), and redownload/install TF2 and maybe the Source SDK as well if you copied that. Steam most likely is detecting those versions are old, and cannot update them without the correct registry/file sizes/etc.
     
  8. Warchamp7

    Warchamp7 L2: Junior Member

    Messages:
    73
    Positive Ratings:
    16
    I had this program when I moved Steam from my C drive to my D drive. I forget exactly how I fixed it.

    Have you tried "Refresh SDK Content"? Also try "Edit Game Configurations", select Team Fortress 2 and click Edit. Check if the directory is correct there.
     
    Last edited: Jun 29, 2009
  9. bakentake

    bakentake L1: Registered

    Messages:
    26
    Positive Ratings:
    12
    Soo, just had to edit game config :p

    I still get the pop up

    Warning
    The configuration information for the game you're trying to edit is invalid or missing.

    then I just click run anyway and hammer launches. Hopefully no more problems.

    No longer getting that popup.
     
    Last edited: Jun 29, 2009