Hammer 3d view. Using mouse to turn left turns me right. PLZ HELP!

Discussion in 'Mapping Questions & Discussion' started by Hunky_YumYum, Sep 27, 2015.

  1. Hunky_YumYum

    Hunky_YumYum L1: Registered

    Messages:
    8
    Positive Ratings:
    2
    In the 3d view, when using z to move around, if I move my mouse left it's like there's something pushing it right and it's stuttery when turning left. If I move the mouse slow enough it won't go left at all and just go right. Turning right works fine and I'll often turn all the way right to go left. This doesn't happen in anywhere else, games, windows, software. I don't have any mouse acceleration either. This makes it really hard to work and I would love a fix.​

    Windows 8
    Razer Imperator mouse
    Hammer build 6907

    I don't know what info is relevant so feel free to ask for anything.
     
  2. Izotope

    aa Izotope Never releases maps

    Messages:
    625
    Positive Ratings:
    592
    Tools -> Options
    [​IMG]
     
  3. Hunky_YumYum

    Hunky_YumYum L1: Registered

    Messages:
    8
    Positive Ratings:
    2
    Thanks, the problem isn't with the y-axis but the x. Toggled Reverse mouse Y axis on/off with no change in the problem but my up-down look was reversed. Left goes right. Right goes right. Using space rather than Z still has the issue occur
     
  4. Crash

    aa Crash func_nerd

    Messages:
    3,190
    Positive Ratings:
    4,918
    Are you using any kind of "game enhancer" software, by chance?
     
  5. Hunky_YumYum

    Hunky_YumYum L1: Registered

    Messages:
    8
    Positive Ratings:
    2
    Razer Synapses is the only thing that could fall under this category. Ended all services related to it and restarted hammer. Still there however the problem has been gradually reducing itself over the course of 2 days I've been extensively using the program
     
  6. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    3,992
    I have no idea what your problem is, but I think it's highly unlikely to be with Hammer itself, for once.
     
  7. Hunky_YumYum

    Hunky_YumYum L1: Registered

    Messages:
    8
    Positive Ratings:
    2
    I don't feel like it'd be a hammer thing, but it only happens there. It's a really weird one and has died down to the point where I think the program is comfortably usable only happens when I go REALLY slowly left. Thank you for the support everyone who replied, I'm happy to know there's help if mapping troubles arise.
     
  8. Izotope

    aa Izotope Never releases maps

    Messages:
    625
    Positive Ratings:
    592
    hmm, why not try to run only hammer along with default programs, and none you've installed manually. See if the problem's still there.