Ground Textures and Blending ?

Discussion in 'Mapping Questions & Discussion' started by Sarah, Aug 21, 2008.

  1. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    This has puzzled me some what. I have worked out from some other stock tf2 maps that some of the ground textures have overlays creating the 'worn path' look in places. While looking at the new Lumberyard I wanted to try out this new grass texture. Only trouble is, I use the very same texture on my own map and all I get is the grey coloured bit, there is no sign of green anywhere. I re-scaled the texture and moved it around a bit, but I'm still left with the grey bit only! What am I doing wrong ?
     
  2. luxatile

    aa luxatile deer

    Messages:
    2,289
    Positive Ratings:
    1,348
    First, make it a displacement. Then, in the same tab where you created the displacement, there's a button that says "Paint Alpha". Click on it, and when you click on the displacement while this menu is open, some grass will be added where you click.
     
    • Thanks Thanks x 4
  3. Pocok

    Pocok L1: Registered

    Messages:
    30
    Positive Ratings:
    0
    yes, itt will work. The other useful tool is the invert alpha, it will change the whole texture to green.
     
  4. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    Hey thanks ! I worked out the inverting as well ! Everything was great until I went to compile and got this :


    Placing detail props : 0...1...2...3...4...5...6...7...8...9...Material NATURE/BLENDGROUNDTOGRASS007 uses unknown detail object type tf_forest_grass!
    Material NATURE/BLENDGROUNDTOGRASS007 uses unknown detail object type tf_forest_grass!

    I'm guessing I have to add that but .. to what? where ?

    Sorry I'm new to this :)
     
  5. samn

    samn L4: Comfortable Member

    Messages:
    158
    Positive Ratings:
    47
    When you run the map, do you notice anything wrong?
    If not then you could probably ignore it.
     
  6. Psy

    aa Psy The Imp Queen

    Messages:
    1,705
    Positive Ratings:
    1,465
    I've had that error as well. It would be really nice if somebody could solve it. I want the lovely grass sprites dammit!
     
  7. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    Well I never got that far, vbsp thing crashed before it finished compiling and it's the only thing I've changed since the last compile .. which worked.
     
  8. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    If you are using the new green grass textures you must also do this before they will work properly!!!

    open map> map properties

    then change detail.vbsp to detail_trainyard.vbsp
    and change detail material to detail/detailsprites_trainyard

    That will make the grassy sprites work, if you've got any of the older grass textures that use the yellowy grass detail sprites they wont work, you can have one or the other (green grass or dead grass)
     
    • Thanks Thanks x 24
  9. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    Youme you are my hero ! thanks :D
     
  10. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    No problem, I put the heading in bold so that everyone sees it, I predict a LOT of people will use the new texture and fail to realise this, meaning theres going to be loads of slightly 'odd' feeling maps.
     
    • Thanks Thanks x 1
  11. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    :( I have a new problem. I decided to restart the my ground displacements so my current bsp is just the floor for my map using this grass texture. I changed the detail in the map properties etc but

    Placing detail props : 0...1...2...3...4...5...6...7...8...9..Error! Too many detail props emitted on this map! (64K max!)n


    :unsure:

    I haven't added any props myself so I'm assuming it's something to do with this texture and the sprites.
     
  12. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    Yeah thats a problem caused by the sprites. I don't know if it can be fixed by having more of the other texture when you do alpha paint (the grey one, the detail sprites only appear on the green bit)
    If it can be fixed in this way consider making more of the non-grassy bit.
    If it can't (which is more likely) you'll have to swap some of the texture out for the one that has _nodetail at the end, this one doesn't make the detail sprites so will help reduce the number you have.
    I'd suggest using the _nodetail texture in any areas the player can't get to, so if you've got the players at the bottom of a cliff and the grass at the top where they cant get to, make the texture at the top _nodetail (since detail sprites fade out after about 768 units away from the player they wont notice any difference)

    Basicly you have to use less of the testure and there is nothing else you can do about it.
     
  13. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    Aw I was afraid you'd say that, it's mostly the green I used. I'll have to re work it and hope for the best ! thanks again :)
     
  14. DasMatze

    DasMatze L2: Junior Member

    Messages:
    87
    Positive Ratings:
    31
    Just wanted to say that it is "detail/detailsprites_trainyard" ;)

    DasMatze
     
    • Thanks Thanks x 1
  15. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    Vbsp files can be edited in Notepad and pakratted to make any kind of detail props.
     
    Last edited: Aug 24, 2008
  16. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    That they can. why don't you write a tutorial on it?
     
  17. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    Oh another tut on things i have never used (like fine HDR tuning coz all my maps are still in LDR)... Maybe in a few days...
     
  18. MrStump

    MrStump L1: Registered

    Messages:
    21
    Positive Ratings:
    2
    I am having a slight problem with achieving green grass.

    I've gotten the painting alpha down and it all works, but my problem is this.

    I do the steps of changing detail.vbsp to detail_trainyard.vbsp and changing detail material to detail/detailsprites_trainyard.

    I then have tried every texture on my displacement, but none of them are showing green grass on screen as I paint. And when I compile with yellow grass up in hammer, it does not appear in game (which I expected, reading the bit about not having yellow and green grass at the same time.)

    Yellow grass really doesn't fit my theme. Is there a certain texture needed to get green grass?
     
    • Creative Creative x 1
  19. VelvetFistIronGlove

    aa VelvetFistIronGlove

    Messages:
    567
    Positive Ratings:
    437
    There seems to be a bug in hammer; it doesn't show the green detail sprites. They will show up in-game if you have the detail sprites setting correct.
     
  20. MrStump

    MrStump L1: Registered

    Messages:
    21
    Positive Ratings:
    2
    You were right. I was also using the wrong kind of texture before. I downloaded the lumberyard source and used that one and it worked great.

    nature/blendgroundtograss007 works great, dandelions and all.