game_player_equip quirk.

Discussion in 'Mapping Questions & Discussion' started by TotalMark, Mar 30, 2008.

  1. TotalMark

    TotalMark L6: Sharp Member

    Messages:
    331
    Positive Ratings:
    40
    [​IMG]

    I used a game_player_equip entity to give every player a tf_weapon_flamethrower.

    On every spawn, one showed up.

    I don't know how useful this is, but it proves there are some entities that work, and others that don't. (I'm lookin' at you filter_activator_class and filter_activator_name.)
     
  2. Pseudo

    Pseudo L6: Sharp Member

    Messages:
    319
    Positive Ratings:
    149
    That's how game_player_equip is supposed to work. The problem is that in TF2 you can't equip weapons just by standing on them. Players have to "use" on the item to gain the weapon.
     
  3. TotalMark

    TotalMark L6: Sharp Member

    Messages:
    331
    Positive Ratings:
    40
    I knew that, but the game_player_equip isn't supposed to work for this game (or be used), but it does anyway. That's my point.
     
  4. Avaray

    Avaray L2: Junior Member

    Messages:
    73
    Positive Ratings:
    3
    I know, this is topic from year 2008, but I wont start new topic.
    It seems that entity no longer works in TF2... or Am I doing it wrong?

    Im creating game_player_equip and Im editing with SmartEdit OFF.
    Im adding new string TF_Weapon_FlareGun with value 0 or 1 (both values doesnt work).
    Weapon is not showing like on image from 1st post.

    Do you know anything about it?
    Or maybe there is other way to equip specific weapon on player?
    I wont use sourcemod for this :huh: