Fullbright issue

Discussion in 'Mapping Questions & Discussion' started by Crrrrrrystal, Sep 27, 2017.

  1. Crrrrrrystal

    Crrrrrrystal L1: Registered

    Messages:
    25
    Positive Ratings:
    30
    So I just got back from the end of a dying imp, didn't get much info but some people were complaining about the map being fullbright. From my perspective, this doesn't seem to be true.
    upload_2017-9-27_13-56-9.png
    Now, one problem that has happened is that even through I compiled cubemaps and they seemed to work on my final compile, it didn't show as working on the server (shiny metal props). Is this what they are referring to? If they really are seeing fullbright, why and how do i fix that if I see lighting fine?
     
  2. Vel0city

    aa Vel0city personal pick-pocketing parrot

    Messages:
    1,880
    Positive Ratings:
    1,487
    Did you compile with HDR only? That causes people with HDR turner off to get fullbright.
     
  3. Crrrrrrystal

    Crrrrrrystal L1: Registered

    Messages:
    25
    Positive Ratings:
    30
    If I turn off my own HDR, the map still has proper lighting. The metal props such as saws are still shiny, and the mirrors and windows don't have any black/pink, indicating that cubemaps work somewhat
     
  4. Crash

    aa Crash func_nerd

    Messages:
    3,066
    Positive Ratings:
    4,553
  5. Crrrrrrystal

    Crrrrrrystal L1: Registered

    Messages:
    25
    Positive Ratings:
    30
    I believe this time I used compilepal, yes.
     
  6. Crash

    aa Crash func_nerd

    Messages:
    3,066
    Positive Ratings:
    4,553
  7. Crrrrrrystal

    Crrrrrrystal L1: Registered

    Messages:
    25
    Positive Ratings:
    30
    Final, without the "game" option.
     
  8. Crrrrrrystal

    Crrrrrrystal L1: Registered

    Messages:
    25
    Positive Ratings:
    30
    Sorry, that's "Publish"
     
  9. iiboharz

    aa iiboharz Meme Queen

    Messages:
    700
    Positive Ratings:
    1,025
    Heads up: "Publish" is designed for CS:GO, which doesn't have LDR. So people playing with HDR turned off definitely are getting a fullbright map.
     
    • Agree Agree x 1
  10. Pocket

    aa Pocket func_croc

    Messages:
    4,480
    Positive Ratings:
    2,212
    Also maybe people are saying "fullbright" when they actually mean "too bright". Which it definitely appears to be, from the picture. The default exposure settings for HDR mode tend to do this; try including an env_tonemap_controller in your map and playing with the settings.