Flickering ceiling

Discussion in 'Mapping Questions & Discussion' started by Pocket, Aug 26, 2010.

  1. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    So, another bizarre bug is going on. My concrete ceilings that I'm using nature/ground_04 are black except when I'm looking from one of a few very specific angles. Observe:

    [​IMG]

    The one on the left is OK because I changed it to concrete/concretefloor002b, but it was the same way before that. And I have other nature/ground_04 ceilings in the same map that are just fine! So I'm at a loss.
     
  2. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Are you sure there's no Z-fighting going on? Or areaportal leakage?
     
  3. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    I thought it might be z-fighting with a nodraw, so I deleted the ceiling to check, and there was nothing there. I'll look at the log next time I compile to see if it's the areaportals.
     
  4. Pocket

    aa Pocket func_croc

    Messages:
    4,489
    Positive Ratings:
    2,219
    Well, I compiled again today, and there's nothing about areaportals in the log. Nor anything else that looks like an error. Frustrating.
     
  5. Boylee

    aa Boylee pew pew pew

    Messages:
    1,068
    Positive Ratings:
    631
    I had a similar problem recently with a couple of walls, only they weren't flickering, thery were solid black the whole time . I tried duplicating them from the other side of the map (which had no problems) and yet the problem persisted. In the end the only thing I found that fixed them was rebuilding the brushwork from scratch. It didn't work the first time, but the second time I rebuilt it it worked. Still have no idea what the problem actually was.
     
  6. StickZer0

    aa StickZer0 💙💙💃💙💙

    Messages:
    664
    Positive Ratings:
    667
    I know that ages ago when you could use prop textures, they'd mess up their lighting when used on a brush, but since that's no longer possible and you didn't say you were using a prop texture, I highly doubt that's the case.
     
  7. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,113
    Positive Ratings:
    6,084
    I'm getting the same thing. the surface is dev textured the same as the other side, and theres a pair of lights in the room.

    [​IMG]

    Its just those faces.
     
  8. Terr

    aa Terr Cranky Coder

    Messages:
    1,591
    Positive Ratings:
    405
    Copy-paste everything to a new VMF?