fixing the weird shadow

Discussion in 'Mapping Questions & Discussion' started by Asd417, Jul 4, 2017.

  1. Asd417

    aa Asd417 L1: Registered

    Messages:
    804
    Positive Ratings:
    560
    This is the ingame view
    [​IMG]
    You can identify the unnatural shadow

    This is the hammer view
    [​IMG]
    This is with func_detail marked
    [​IMG]
    These screenshots show how these func_details are separated
    [​IMG]
    [​IMG]
    Lightmap grid is fine

    How do I fix this shadow?
    EDIT: no leaks found
     
  2. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    Having brushes inside a skybox brush causes them to have shadows most of the time because despite the skybox brush emiting the light, it doesn't let any light through.
     
    • Agree Agree x 1
  3. Asd417

    aa Asd417 L1: Registered

    Messages:
    804
    Positive Ratings:
    560
    But how about dustbowl's tower? maxresdefault.jpg
    It uses the same method but it does not seem to have any strange shadows
     
  4. Asd417

    aa Asd417 L1: Registered

    Messages:
    804
    Positive Ratings:
    560
    dustbowl_example1b.jpg
    edit: Also, the weird shadow also appears on func_detail that is not touching the skybox brush. How about that shadow?
     
  5. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,742
    I don't know why Source does weird things to brushes intersecting skybox brushes, or how to stop it but....

    Thoughts:
    • It's entirely possible that a displacement face might not suffer the same issue, and since sheet metal on a roof is often made from displacements, that might be a good solution here.
    • It could be caused by lower than max compile settings. If there are fewer bounces, or rays fired that could easily cause something screwy. Try doing a compile with -final if you haven't already
    • That's a rooftop, it won't be seen much and by the looks of how they should be lit and shadowed, the faces should be fairly even. You could mask the issue by dropping the lightmap size to 64, or even down to 256+ to smooth out the entire face to just one or two luxels
    And for the nearer roof, these both look like smoothing errors so:
    • Use hammer's smoothing groups to manually separate these faces
    • Change -smooth in vrad to a lower value, the default is 45 and any two faces with an adjoining angle below that will be automatically smoothed
    • Change the lightmap scale on one of the faces to be different from the other, this will prevent them from being smoothed
    • Make the angle steeper or hide the error with another brush
    • For the near, thin, roof it looks like it's smoothing with the face touching the wall as well as the other side of the roof, simply nodraw that face