[Fixed] [MvM] Robots not spawning in spawn

Discussion in 'Mapping Questions & Discussion' started by HolySnickerPuffs, Jun 18, 2017.

  1. HolySnickerPuffs

    aa HolySnickerPuffs

    Messages:
    1,017
    Positive Ratings:
    1,395
    Me and my group have a problem on our map, Helix. Our map has three main robot spawns. Two in the "A" section of our map, and one in the "B" section of the map. The two in the "A" section work, but for some reason the "B" spawn does not spawn the robots in the spawn room, but instead on ground level.

    We don't know how to fix this. Please help!

    screen1.PNG

    (The Green is where the robots spawn. The blue structure is where the robots -should- spawn. The nodraw are respawnvisualizers. The trigger brushes are the path that the robots take to the bomb site.)

    I've included the VMF for only the "B" spawn, as I still firmly believe that the problem is with the blue spawn itself. If I am wrong, I can supply the entire map's VMF.
     

    Attached Files:

  2. zahndah

    aa zahndah professional letter

    Messages:
    724
    Positive Ratings:
    631
    Does the "B" spawn have a nav mesh where the bots should be spawning? if not mark it with nav_mark_walkable then put nav_generate_incremental into the console to generate a nav mesh there.
     
    • Thanks Thanks x 2
  3. HolySnickerPuffs

    aa HolySnickerPuffs

    Messages:
    1,017
    Positive Ratings:
    1,395
    That worked.

    How the hell was it that easy.
     
  4. Freyja

    aa Freyja It hurt itself in it's confusion!

    Messages:
    2,915
    Positive Ratings:
    5,305
    Make sure to do nav_analyze after that or bots will effectively be drunk and blind
     
    • Funny Funny x 2
    • Thanks Thanks x 1
    Last edited: Jun 18, 2017
  5. henke37

    aa henke37

    Messages:
    2,024
    Positive Ratings:
    487
    Who is note?
     
  6. Crowbar

    aa Crowbar Live demonstration of the hairy ball theorem

    Messages:
    1,457
    Positive Ratings:
    1,270
    My guess is mistyped bots.
    Second thought: Might have been autocorrection. If so I feel you frey, autocorrection/autocompletion gets in the way so much when typing specific terminology but without it typing is hella slow
     
    Last edited: Jun 18, 2017
  7. Sarexicus

    Sarexicus L1: Registered

    Messages:
    15
    Positive Ratings:
    14
    damn you auto carrot
     
    • Funny Funny x 1
  8. Freyja

    aa Freyja It hurt itself in it's confusion!

    Messages:
    2,915
    Positive Ratings:
    5,305
    Yes it was an auto correct mistake
     
Tags: