[FIXED] Hammer game configurations missing

Discussion in 'Mapping Questions & Discussion' started by Sp00k, Jul 29, 2017.

  1. Sp00k

    Sp00k L1: Registered

    Messages:
    28
    Positive Ratings:
    4
    You know how when you launch hammer it asks you to pick a game configuration? (example: "Half-Life" or "Team Fortress 2") Well for me it isn't showing either. Instead it says that hammer is missing game configurations and asks me to manually set one up. I didn't have to do this when I first started so I'm not sure why it's asking me to do it now. On a side note, I did migrate my windows 10 account files to another one and the game configs might have gotten left out. So my question is:

    Is there any way to restore game configuration files into Hammer editor?
     
  2. Egan

    aa Egan

    Messages:
    1,318
    Positive Ratings:
    1,507
    You may need to simply, prior to running hammer.exe, run hammer.bat which sets up the 'VPROJECT' variable (idk what that does really, but it sounds like it would help).

    Also if you haven't run TF2 yet, do that, and afterwards try verifying game content through the steam library.
     
  3. Sp00k

    Sp00k L1: Registered

    Messages:
    28
    Positive Ratings:
    4
    Running hammer.bat brought me to the same error dialogue and I've already tried verifying game files and running TF2
     
  4. Egan

    aa Egan

    Messages:
    1,318
    Positive Ratings:
    1,507
    You might then just have to manually remake the Team Fortress 2 game configuration inside hammer's Tools/Options.. dialog window through the Edit button:

    [​IMG]

    you just need the 'base' and 'tf' FGD files. my base file was still located in my sourcesdk directory but it should also be located in the tf2 bin directory for you.

    [​IMG]

    Edit: Supposedly if we were still running through Source SDK you'd be able to reset the game configuration to the default properties through the sdk, but the above method should also work.
     
  5. Sp00k

    Sp00k L1: Registered

    Messages:
    28
    Positive Ratings:
    4
    I created a test config and them clicked "Remove" and it added the default configs back in haha, thanks anyway
     
    • Like Like x 1