First time making a map, stuck at spawn

Discussion in 'Mapping Questions & Discussion' started by BOT Arnold, Aug 1, 2013.

  1. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Last edited: Aug 2, 2013
  2. DonutVikingChap

    DonutVikingChap L5: Dapper Member

    Messages:
    226
    Positive Ratings:
    142
    Raise your spawnpoints slightly off the ground.
     
    • Thanks Thanks x 1
  3. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Ty, 1st problem solved

    But, somehow blue and red are sharing the same spawn points no matter ive set the spawn points to red only. Anyone help? ty
     
    Last edited: Aug 1, 2013
  4. DonutVikingChap

    DonutVikingChap L5: Dapper Member

    Messages:
    226
    Positive Ratings:
    142
    You do have the BLU spawns set up too, right? If not, that must be the problem.
     
  5. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Yes I have them setted up.
     
  6. RaVaGe

    aa RaVaGe

    Messages:
    723
    Positive Ratings:
    1,020
    info_player_teamspawn :

    TFTeam:

    Team <choices>
    Team

    0 : Any
    2 : Red
    3 : Blue

    Note:If you have ANY team_control_point_round entities in your map, you MUST also set the '<team> spawn for round' settings below. If this is not done both teams will spawn at all spawn points.

    https://developer.valvesoftware.com/wiki/Info_player_teamspawn

    You made a mistake somewhere because there is not 100 solutions about that.
     
  7. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    I am sure I have set them correctly, all blue spawns are Blue and all red spawns are set to RED.
     
  8. Headhunter09

    Headhunter09 L1: Registered

    Messages:
    47
    Positive Ratings:
    6
    If you have any spawns set to ANY then having BLU and RED spawns properly configured will be irrelevant.
     
  9. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    I see, mapping is complicated...

    How is this leak possible?

    [​IMG]
     
  10. Fish 2.0

    Fish 2.0 L6: Sharp Member

    Messages:
    324
    Positive Ratings:
    116
    func_detail?
     
  11. Vaconcovat

    Vaconcovat L3: Member

    Messages:
    116
    Positive Ratings:
    88
    its not a func_detail because he is in groups mode and it says 'a solid with 6 faces'

    the only other (valid) reason for a leak going through a solid brush is if that soild has any of its faces using a transparent texture. Make sure ALL faces of that brush are using solid textures.

    If it still doesn't work, there are a bunch of weird tricks like completely remaking the brush, splitting the brush in half or re-naming your vmf file.

    It's hammer. Don't get your hopes up.
     
  12. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Thanks, found out 1 face has a trigger texture.

    Btw, heres how the map looks
    [​IMG]


    How to create solids that can shoot through but not walk through. Thanks for the help guys
     
  13. colacan

    colacan L5: Dapper Member

    Messages:
    235
    Positive Ratings:
    66
    Brushes with the playerclip texture will block players, but nothing else.
     
  14. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    About the blue spawn, I checked entity report and i theres no problem at all.. I have all spawns set to either red or blue.

    Also, I have placed 2 prop_dynamics and have set the model to sawblade_moving.mdl but the sawblade doesnt move in game....
     
    Last edited: Aug 2, 2013
  15. Faux Rhinoceros

    aa Faux Rhinoceros Also known as Dr. Element

    Messages:
    1,470
    Positive Ratings:
    1,363
    You will need to set the prop_dynamics default animation to the name of the sawblade models spinning animation. You can see the names of the different animations in the model browser.
     
  16. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    thanks, now working..

    btw i have no idea how to fix my blue spawn..
     
  17. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    Today i tried compiling my map after some major changes, but when i tried to load the map, it crashed. Here is the compile log.


    Code:
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Users\Arnold Lam\Desktop\achievement_hoursplayed_b1.vmf"
    
    Valve Software - vbsp.exe (Jul 24 2013)
    8 threads
    materialPath: C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\materials
    Loading C:\Users\Arnold Lam\Desktop\achievement_hoursplayed_b1.vmf
    fixing up env_cubemap materials on brush sides...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    **** leaked ****
    Entity prop_static (876.00 1761.00 -432.00) leaked!
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (4608.0 4096.0 -248.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (5120.0 3584.0 -248.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3072.0 3584.0 -464.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3072.0 3584.0 -168.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3584.0 4096.0 -248.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (5120.0 2560.0 -248.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (5120.0 1536.0 -248.0)
    Leaf 0 contents: 
    Leaf 1 contents: CONTENTS_SOLID 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    
    FindPortalSide: Couldn't find a good match for which brush to assign to a portal near (3072.0 2560.0 -504.0)
    Leaf 0 contents: CONTENTS_SOLID 
    Leaf 1 contents: 
    viscontents (node 0 contents ^ node 1 contents): CONTENTS_SOLID 
    This means that none of the brushes in leaf 0 or 1 that touches the portal has CONTENTS_SOLID 
    Check for a huge brush enclosing the coordinates above that has contents CONTENTS_SOLID 
    Candidate brush IDs: 
    
    *** Suppressing further FindPortalSide errors.... ***
    Processing areas...done (0)
    Building Faces...done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...done (0)
    Merging details...done (0)
    FixTjuncs...
    PruneNodes...
    WriteBSP...
    done (0)
    Creating default LDR cubemaps for env_cubemap using skybox materials:
       skybox/sky_day01_01*.vmt
     ! Run buildcubemaps in the engine to get the correct cube maps.
    Creating default HDR cubemaps for env_cubemap using skybox materials:
       skybox/sky_day01_01*.vmt
     ! Run buildcubemaps in the engine to get the correct cube maps.
    Finding displacement neighbors...
    Finding lightmap sample positions...
    Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
    Building Physics collision data...
    done (1) (135306 bytes)
    Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
    Water found with no water_lod_control entity, creating a default one.
    Compacting texture/material tables...
    Reduced 115 texinfos to 84
    Reduced 25 texdatas to 22 (646 bytes to 499)
    Writing C:\Users\Arnold Lam\Desktop\achievement_hoursplayed_b1.bsp
    1 second elapsed
    
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Users\Arnold Lam\Desktop\achievement_hoursplayed_b1"
    
    Valve Software - vvis.exe (Jul 24 2013)
    8 threads
    reading c:\users\arnold lam\desktop\achievement_hoursplayed_b1.bsp
    reading c:\users\arnold lam\desktop\achievement_hoursplayed_b1.prt
    LoadPortals: couldn't read c:\users\arnold lam\desktop\achievement_hoursplayed_b1.prt
    
    
    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters:  -game "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf" "C:\Users\Arnold Lam\Desktop\achievement_hoursplayed_b1"
    
    Valve Software - vrad.exe SSE (Jul 24 2013)
    
          Valve Radiosity Simulator     
    8 threads
    [Reading texlights from 'lights.rad']
    [34 texlights parsed from 'lights.rad']
    
    Loading c:\users\arnold lam\desktop\achievement_hoursplayed_b1.bsp
    No vis information, direct lighting only.
    Setting up ray-trace acceleration structure... Done (0.32 seconds)
    2577 faces
    361049 square feet [51991076.00 square inches]
    0 Displacements
    0 Square Feet [0.00 Square Inches]
    48 direct lights
    BuildFacelights:     0...1...2...3...4...5...6...7...8...9...10 (2)
    Build Patch/Sample Hash Table(s).....Done<0.0059 sec>
    FinalLightFace:      0...1...2...3...4...5...6...7...8...9...10 (0)
    FinalLightFace Done
    0 of 0 (0% of) surface lights went in leaf ambient cubes.
    ThreadComputeLeafAmbient: 0...1...2...3...4...5...6...7...8...9...10 (1)
    Writing leaf ambient...done
    Ready to Finish
    
    Object names       Objects/Maxobjs  Memory / Maxmem  Fullness 
    ------------       ---------------  ---------------  -------- 
    models                  17/1024          816/49152    ( 1.7%) 
    brushes                377/8192         4524/98304    ( 4.6%) 
    brushsides            2483/65536       19864/524288   ( 3.8%) 
    planes                 844/65536       16880/1310720  ( 1.3%) 
    vertexes              3417/65536       41004/786432   ( 5.2%) 
    nodes                 1292/65536       41344/2097152  ( 2.0%) 
    texinfos                84/12288        6048/884736   ( 0.7%) 
    texdata                 22/2048          704/65536    ( 1.1%) 
    dispinfos                0/0               0/0        ( 0.0%) 
    disp_verts               0/0               0/0        ( 0.0%) 
    disp_tris                0/0               0/0        ( 0.0%) 
    disp_lmsamples           0/0               0/0        ( 0.0%) 
    faces                 2577/65536      144312/3670016  ( 3.9%) 
    hdr faces                0/65536           0/3670016  ( 0.0%) 
    origfaces             1177/65536       65912/3670016  ( 1.8%) 
    leaves                1310/65536       41920/2097152  ( 2.0%) 
    leaffaces             2739/65536        5478/131072   ( 4.2%) 
    leafbrushes            676/65536        1352/131072   ( 1.0%) 
    areas                    3/256            24/2048     ( 1.2%) 
    surfedges            16375/512000      65500/2048000  ( 3.2%) 
    edges                 9597/256000      38388/1024000  ( 3.7%) 
    LDR worldlights         48/8192         4224/720896   ( 0.6%) 
    HDR worldlights          0/8192            0/720896   ( 0.0%) 
    leafwaterdata            1/32768          12/393216   ( 0.0%) 
    waterstrips            194/32768        1940/327680   ( 0.6%) 
    waterverts               0/65536           0/786432   ( 0.0%) 
    waterindices          3732/65536        7464/131072   ( 5.7%) 
    cubemapsamples           0/1024            0/16384    ( 0.0%) 
    overlays                 0/512             0/180224   ( 0.0%) 
    LDR lightdata         [variable]     1483924/0        ( 0.0%) 
    HDR lightdata         [variable]           0/0        ( 0.0%) 
    visdata               [variable]           0/16777216 ( 0.0%) 
    entdata               [variable]       24198/393216   ( 6.2%) 
    LDR ambient table     1310/65536        5240/262144   ( 2.0%) 
    HDR ambient table     1310/65536        5240/262144   ( 2.0%) 
    LDR leaf ambient      6425/65536      179900/1835008  ( 9.8%) 
    HDR leaf ambient      1310/65536       36680/1835008  ( 2.0%) 
    occluders                0/0               0/0        ( 0.0%) 
    occluder polygons        0/0               0/0        ( 0.0%) 
    occluder vert ind        0/0               0/0        ( 0.0%) 
    detail props          [variable]           1/12       ( 8.3%) 
    static props          [variable]           1/5092     ( 0.0%) 
    pakfile               [variable]      212089/0        ( 0.0%) 
    physics               [variable]      135306/4194304  ( 3.2%) 
    physics terrain       [variable]           2/1048576  ( 0.0%) 
    
    Level flags = 0
    
    Total triangle count: 6666
    Writing c:\users\arnold lam\desktop\achievement_hoursplayed_b1.bsp
    3 seconds elapsed
    
    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Users\Arnold Lam\Desktop\achievement_hoursplayed_b1.bsp" "C:\Program Files (x86)\Steam\steamapps\common\Team Fortress 2\tf\maps\achievement_hoursplayed_b1.bsp"

    There is definitely a leak, but there is no point file.
    [​IMG]
     
    Last edited: Aug 3, 2013
  18. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    bad area portal?
     
  19. BOT Arnold

    BOT Arnold L1: Registered

    Messages:
    11
    Positive Ratings:
    0
    I have no area portals. I was thinking of optimizing the map after ive finished all the features
     
    Last edited: Aug 4, 2013
  20. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    141
    I've lost track of all the things that can cause that error since most of them are obvious.

    Could it be that you have a prop of some sort completely inside of a world brush? That happened to be one time when I thought i had turned a brush into a trigger_multiple but forgot. It caused a bad error but forgot if that was the error.