First sounds

Discussion in 'Off Topic' started by GrimGriz, Mar 4, 2009.

  1. GrimGriz

    GrimGriz L10: Glamorous Member

    Messages:
    774
    Positive Ratings:
    133
    I don't know if anyone has ever had this or not, but I was thinking it's possible and someone might know a fix, so here goes:

    Every time a sound plays for the first time since I started TF2 for the session/day, I lag, seemingly while it loads. i.e. the first time a soldier's rocket fires, the first time someone says "need a sentry here (for each class)". After it plays it doesn't happen again, but the first round or so after I start is pretty miserable.

    Has anyone else had this happen and/or have any idea how i might precache the sounds so this doesn't happen?
     
  2. Ravidge

    aa Ravidge Grand Vizier

    Messages:
    1,544
    Positive Ratings:
    2,492
    there is a console command: cl_forcepreload 1
    I have never used it myself but its description seems to be what you're after... put it in autoexec.cfg and see if there's any change.
     
  3. drp

    aa drp

    Messages:
    2,251
    Positive Ratings:
    2,551
    any similar symptoms in other games? could be your harddrive is going out? is it a 7200, 5400, or 10,000 RPM hd?
     
  4. GrimGriz

    GrimGriz L10: Glamorous Member

    Messages:
    774
    Positive Ratings:
    133
    L4D is the same, but it never happened for peggle nights...I really don't play that many games :)

    I has 2 different hdd, which might have something to do with it as they spin at different speeds :) The one the OS is on is my old sata 10000 rpm 30 gig, and I got a new 300 gig IDE one (where all the game files are).

    Interestingly, I can't find an autoexec.cfg for tf2...
    I has one in:
    name/counte-rstrike/valve
    name/deathmatch classic/valve
    and
    name/half-life/valve,

    but not in hl2 or tf2 or anything...
     
    Last edited: Mar 4, 2009
  5. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,768
    Positive Ratings:
    5,508
    There isn't one by default because all the default settings are saved elsewhere. Just make one in the team fortress 2/tf/cfg folder.