Exporting as Correct File Types?

Discussion in 'Mapping Questions & Discussion' started by ♠♣DσshDσsh♣♠, Mar 14, 2011.

  1. ♠♣DσshDσsh♣♠

    ♠♣DσshDσsh♣♠ L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I'm sure this is easy for most of you, but I can't ever seem to find out how to export my map(s) correctly as .bsp or .nav or whatever it needs to be, then it ends up not being used and wasting my file space. Could someone please tell me how to export it correctly? Export saves it as .vmf and the same with saving.
     
  2. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
    Push F9. You want to compile, not export.

    Edit: To generate a nav for bots, once you're in game, type

    sv_cheats 1
    nav_generate

    You may want to read up on editing nav meshes. http://developer.valvesoftware.com/wiki/Navigation_Mesh_Commands

    You're making a Gravel Pit style map, right? I don't remember if bots understand Gravel Pit or not.
     
    Last edited by a moderator: Mar 14, 2011
  3. ♠♣DσshDσsh♣♠

    ♠♣DσshDσsh♣♠ L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    But then it says it needs a .bsp file of the map to do so.
    Edit: I've pressed YES to follow along even though it failed, of course needing the .bsp, and now it's given me a .dxf?
     
  4. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
    What are you doing? In Hammer, open your map vmf. Hit F9, or this, :compile:, or go to File -> Run Map. Make sure you have vrad and vvis on Fast and BSP on Normal. Don't do HDR. It should be fine.

    If your map isn't even generating a BSP before moving onto lighting, you have a problem. Usually my issue is an invalid solid. Hit Alt+P and look for errors.
     
  5. ♠♣DσshDσsh♣♠

    ♠♣DσshDσsh♣♠ L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I've searched for problems, and there's a big list of them, except I don't see what half of them mean:

    Entity (trigger_capture_area) had bad I/O connections
    Entity (trigger_capture_area) had bad I/O connections
    Entity (trigger_multiple) has bad I/O connections
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Entity keyvalue "controlpoint" refers to a missing target
    Overlay with no assigned faces
    There is no player start - Odd, because I have both RED and BLU spawns
     
  6. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
    Okay, the first three are bad inputs or outputs. Select them and click "Go to error" and see what is wrong. It looks like your control points (judging from the next 10 or so items) are very broken. You also have an overlay that isn't attached to anything.

    Player start doesn't really matter. It doesn't refer to spawn points.

    Not one of those, though, should be stopping you from compiling. Is your SDK set up correctly?
     
  7. Seba

    aa Seba DR. BIG FUCKER, PHD

    Messages:
    2,363
    Positive Ratings:
    2,365
    Bookmark this and run your compile log through it every time you have a problem. If the instructions on interlopers don't fix it, come to chat and ask for help.
     
  8. ♠♣DσshDσsh♣♠

    ♠♣DσshDσsh♣♠ L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    Ok, so now I fixed all those errors, but compiling still doesn't give me any .bsp files for the map, and I've checked both TF2 maps and sourcesdk_content or whatever it's called.
     
  9. StickZer0

    aa StickZer0 💙💙💃💙💙

    Messages:
    664
    Positive Ratings:
    667
    It should say in the compile log where it copied the BSP to when it's done - try posting us your compile log so we can see what's happening.
     
  10. Sergis

    aa Sergis L666: ])oo]v[

    Messages:
    1,871
    Positive Ratings:
    1,130
    Compile log bitte.
     
  11. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
    Are you sure it isn't in your tf/maps folder? The game should start automatically for you.

    Are you on a 64 bit system?
     
  12. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    it's in
    Steam/steam apps/user name/teamfortress2/tf/maps
    (I believe, away from my comp right now)
     
  13. ♠♣DσshDσsh♣♠

    ♠♣DσshDσsh♣♠ L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    I can't see it anywhere in teamfortress2/tf/maps/, and all there is is .lin, .vmx, .vmf and .dxf, no .bsp.
     
  14. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
  15. ♠♣DσshDσsh♣♠

    ♠♣DσshDσsh♣♠ L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    Alright, I did that, it's here

    edit:
    No it was meant to be Dustbowl style, if you mean gamemode-wise.
     
    Last edited: Mar 14, 2011
  16. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    #
    0...1...2...3...4...5...6...7...8...9...10**** leaked ****
    #
    Entity func_door (256.00 -4219.99 63.75) leaked!

    you have a leak.

    map/load pointfile. follow the red line until it goes outside your map. seal the hole.
    compile, check again. It'll only show one leak at a time. Once they are all fixed you can compile and go in game.


    #
    Error opening c:\program files\steam\steamapps\lfoo\sourcesdk_content\tf\mapsrc\cp_dirtmound.bsp

    when it says error opening, that means it didn't save that file (because of leak) so there is no map file to open and go in game to.
    -------
    when it does save it should be in the folder I pointed to in my above post.
     
  17. Sergis

    aa Sergis L666: ])oo]v[

    Messages:
    1,871
    Positive Ratings:
    1,130
    it would compile with the leak. i think this
    is the real problem because vbsp stops there. cut the brush the overlay is on into a few smaller ones.
    of course the leak must be fixed too.
     
  18. red_flame586

    red_flame586 L7: Fancy Member

    Messages:
    437
    Positive Ratings:
    108
    That could be caused by the fact that you've used the carve tool and stuck an overlay on top of that. If you did, don't use the carve tool ever (it's baaaaaad). Otherwise, just try removing the overlay at that point.
     
  19. ♠♣DσshDσsh♣♠

    ♠♣DσshDσsh♣♠ L1: Registered

    Messages:
    12
    Positive Ratings:
    0
    How do I cut the overlays?

    edit:
    Thanks, I tried this, then compiled again and it gave me my mapname.bsp. :D
     
    Last edited: Mar 15, 2011
  20. LeSwordfish

    aa LeSwordfish semi-trained quasi-professional

    Messages:
    4,105
    Positive Ratings:
    6,003
    You dont cut the overlays, you cut the brush.
     
    • Thanks Thanks x 1