Everything in map suddenly deleted - VMX and BSP not working either.

Discussion in 'Mapping Questions & Discussion' started by Riftex, Aug 27, 2017.

  1. Riftex

    Riftex L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Alright, I've been searching for someone with a similar problem, but to no avail.

    I tried to open up my map in Hammer, and when I loaded the file, it loaded normally with no errors. The only problem is that there is now nothing in the map, its essentially no different from a completely new file. There are no visgroup tabs.​

    The only peculiar behavior of hammer that I can recall happened the day before this incident. Every time I tried to compile the map to walk through it in game Hammer simply stopped responding and I was forced to close it, however, when I opened it back up everything was perfectly untouched. I continued to try different methods to get my map compiled, but the problem persisted until I basically gave up and shut down my PC for the night.​

    So now I'm here trying to open it up again today, but now the map is completely empty, its all disappeared without a trace. When I tried renaming the VMX file to see if that would work, this was also empty, and I tried to use both VMEX and BSPSRC to decompile the .bsp without any success. I'm not sure if this is an extremely easy to solve issue or a very rare one, since I have yet to find any other thread with my problem.

    When I try to open TF2 and launch the map from there, I click "create server" and then nothing happens.​

    Autosaves are also not an option because I'm an idiot and didn't realize that you have to enable them before a problem actually arises.

    Here is the compile log of the map, this should be from the day that it was not responding, though I'm not 100% sure.
     

    Attached Files:

  2. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,006
    Positive Ratings:
    1,160
    First of all, it's normal for Hammer to stop responding during a compile, even if the map isn't very big yet. It's still working in the background as long as one of the compile processes (vbsp.exe, vvis.exe, vrad.exe) is running in the task manager.

    Now, for your problem: if your vmf's filesize is the same as it was before, but shows up as as nothing but whitespace characters when opened in a text editor, then I'm sorry to say it's gone. As far as I'm aware, no one has been able to reverse this bug. In my personal experience it seems to happen mostly whenever the computer shuts down while the vmf is being read or written - so if it goes off during a manual save or a compile (when the vmf is copied to the automatic vmx backup) then it's probably toast. (Note that the compile processes don't automatically stop when Hammer is closed; they have to be killed individually in the task manager.)

    My usual advice for this situation is to check autosaves or decompile your bsp, but it seems you've tried those already. The vmx typically won't help you either, as you've found. So your only other bet is probably restoring the vmf and/or bsp from file history if you had it backed up somewhere.
     
    • Thanks Thanks x 1
  3. Riftex

    Riftex L1: Registered

    Messages:
    2
    Positive Ratings:
    0
    Thanks, luckily I wasn't too far in with creating the map, so it may only take a day of me really concentrating to recreate it from how I remember it.

    Though I've learned a new lesson, autosave will always be on from now on in my future projects.
     
  4. DrSquishy

    DrSquishy L9: Fashionable Member

    Messages:
    683
    Positive Ratings:
    223
    You can also decompile the BSP if you've compiled it previously but the map breaks. My map just broke, after over 100 hours of work. Thankfully I upload every compile to dropbox so I didn't lose too much