Everything disappeared problem

Discussion in 'Mapping Questions & Discussion' started by critMagnet, Aug 7, 2016.

  1. critMagnet

    critMagnet L1: Registered

    Messages:
    4
    Positive Ratings:
    1
    So today I launched a map i was working on yesterday, and all the props disappeared, spawn entities turned green (Half Life 2 spawn entities, I think?) everything was ungrouped and only the brushes and textures stayed.
    Is there a way to fix it?
     
  2. KubeKing

    Server Staff KubeKing dan's birthday was fun too

    Messages:
    1,247
    Positive Ratings:
    1,510
    Before you go any further, find/make copies of some autosaves of the map. Go to your main drive, then the folder HammerAutosaves, and copy any files that share the map name (sort by Recently Edited).

    Once you have those backups copied, verify your game cache. I'm on mobile, but you can do easily find a tutorial to do this online. Then, check the original vmf and report back.
     
  3. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,005
    Positive Ratings:
    1,157
    Did Hammer at any point ask you to re-save your map with invalid solids removed, and if so, did you say yes? There's an ancient bug that can trigger when you choose this option that takes every entity in your map down with it. Unfortunately there is no way to directly undo this, but if you have autosaves, a VMX file, or a recently compiled BSP of your map, then it's possible to recover some of your work.
     
    • Agree Agree x 2
  4. critMagnet

    critMagnet L1: Registered

    Messages:
    4
    Positive Ratings:
    1
    Can't find it :/
     
  5. KubeKing

    Server Staff KubeKing dan's birthday was fun too

    Messages:
    1,247
    Positive Ratings:
    1,510
    Can't find the autosaves? If your main drive is C, the folder should be "C:\HammerAutosave". Sort by "Date Modified".

    Can't find out how to verify your game cache? Check out this tutorial.

    Edit: For the HammerAutosave folder, you might as well check all of your drives, it might be the one you have TF2 installed in.
     
  6. critMagnet

    critMagnet L1: Registered

    Messages:
    4
    Positive Ratings:
    1
    Not a single HammerAutosave folder on both of the drives.
    I guess I should just verify my TF2 and make a new map :/
     
  7. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,005
    Positive Ratings:
    1,157
    The quickest way to find out where they're stored is by opening up Hammer, clicking Tools > Options, and going to the General tab. Your autosaves will be in the directory listed, assuming you even had them enabled to begin with.

    [​IMG]

    If you didn't have them set up, don't worry - you can still try the VMX, which is saved in the same place as your VMF, or any compiled BSPs you might have. Try moving the VMX to a different folder (to avoid a name conflict), changing the extension to VMF, and opening it up. Did it store a version of your map with everything still intact?
     
  8. critMagnet

    critMagnet L1: Registered

    Messages:
    4
    Positive Ratings:
    1
    Well crap, it was disabled the whole time and I didn't even know about it.

    But after this thing happened (or before) my TF2 got magically uninstalled (thanks gabe), maybe this is what messed it up :<
     
    • Agree Agree x 1