Error when I try to 'run map'.

Discussion in 'Mapping Questions & Discussion' started by Araluex, Oct 18, 2015.

  1. Araluex

    Araluex L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    Hi,

    For some reason I'm getting this error message when I try to run my map: https://gyazo.com/5d349b3cba87132af0476832004945b3

    Can anyone help?
    ------------------------------------------------------------------------------------------------------------------------------
    Not sure if this is relevant but this is the compiling message:


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vbsp.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\pleasework.vmf"

    Valve Software - vbsp.exe (Oct 14 2015)
    8 threads
    materialPath: C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf\materials
    Loading C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\pleasework.vmf
    material "custom_minecraft/pbd_plank" not found.
    Material not found!: CUSTOM_MINECRAFT/PBD_PLANK
    ConVarRef mat_reduceparticles doesn't point to an existing ConVar
    Can't find surfaceprop mudslipperyslime for material /MCLAVA, using default
    Patching WVT material: maps/pleasework/dev/dev_blendmeasure_wvt_patch
    fixing up env_cubemap materials on brush sides...
    Material MClava is depending on itself through materialvar $bottommaterial! Ignoring...
    Material mcwater is depending on itself through materialvar $bottommaterial! Ignoring...
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
    Processing areas...done (0)
    Building Faces...Can't find surfaceprop mudslipperyslime for material MClava, using default
    done (0)
    Chop Details...done (0)
    Find Visible Detail Sides...Bad detail brush side


    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vvis.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\pleasework"

    Valve Software - vvis.exe (Oct 14 2015)
    8 threads
    reading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\pleasework.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\pleasework.bsp

    ** Executing...
    ** Command: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\bin\vrad.exe"
    ** Parameters: -game "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf" "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\pleasework"

    Valve Software - vrad.exe SSE (Oct 14 2015)

    Valve Radiosity Simulator
    8 threads
    [Reading texlights from 'lights.rad']
    unknown light specifier type - lights

    [56 texlights parsed from 'lights.rad']

    Loading c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\pleasework.bsp
    Error opening c:\program files (x86)\steam\steamapps\common\team fortress 2\sourcesdk_content\tf\mapsrc\pleasework.bsp

    ** Executing...
    ** Command: Copy File
    ** Parameters: "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\sourcesdk_content\tf\mapsrc\pleasework.bsp" "C:\Program Files (x86)\Steam\SteamApps\common\Team Fortress 2\tf\maps\pleasework.bsp"

    The command failed. Windows reported the error:
    "The system cannot find the file specified."
     
  2. zahndah

    aa zahndah professional letter

    Messages:
    718
    Positive Ratings:
    627
    Just saying, those skyboxes look messy. Also its better to have them just around the outside areas of the map, and not too far out. I know it doesn't answer your question but its just some general advice for you.
     
  3. Vel0city

    aa Vel0city func_fish

    Messages:
    1,931
    Positive Ratings:
    1,540
    VBSP isn't finishing up the compile process due to some error. VVIS can't find the bsp file, so it can't compile. VRAD can't find the same bsp file so it also can't compile.

    First, you have some material called CUSTOM_MINECRAFT/PBD_PLANK that VBSP can't find, so make sure that that's also fixed (see the Material not found!: CUSTOM_MINECRAFT/PBD_PLANK error).

    But it's this guy that screws it up in the first place: "Find Visible Detail Sides...Bad detail brush side"

    According to interlopers.net/errors (which you should use before posting compile logs) is that you have multiple incompatible tool textures (hint, skip, nodraw, trigger, etc) on one brush. Fly around your map a look for one (or multiple) brushes that have these textures on them, then recompile.
     
    • Thanks Thanks x 1
    Last edited: Oct 18, 2015
  4. ics

    aa ics http://ics-base.net

    Messages:
    723
    Positive Ratings:
    438
    Find Visible Detail Sides...Bad detail brush side

    This is causing it to fail. Check alt+p for errors. You might have a small brush marked as func_detail that is too small for compiler to understand or any other small brush.
     
    • Thanks Thanks x 1
  5. Araluex

    Araluex L1: Registered

    Messages:
    14
    Positive Ratings:
    0
    Thank you!
     
  6. SeanMcPhearless

    SeanMcPhearless L2: Junior Member

    Messages:
    91
    Positive Ratings:
    51
    I'm having this same problem where it can't find the file specified, I think I see some brushes that might be causing the problem. What exactly do I do to them? The brush texture seems to always be darker than the identical brush texture next to it and I cant ctrl alt the brighter texture over. i don't know if this is actually the problem though.
     
  7. Lampenpam

    aa Lampenpam

    Messages:
    1,019
    Positive Ratings:
    337
    heh, no don't worry about that. When you set your 3d view to "3D shaded textured polygone" it makes faces which face in certain directions darker, so it's easier to see in a map full of dev-textures. Set the view to "3D textured" if you don't want this effect. Naturally this has no effect on the compile.
     
    • Thanks Thanks x 1
  8. Vel0city

    aa Vel0city func_fish

    Messages:
    1,931
    Positive Ratings:
    1,540
    Alt+P is your friend here, it's the problem solver. Although the compile log usually says what failed with VBSP which is almost always the reason why "Windows can't find the file specified".
     
    • Thanks Thanks x 1
  9. SeanMcPhearless

    SeanMcPhearless L2: Junior Member

    Messages:
    91
    Positive Ratings:
    51
    ok! Thanks!!