env_sprite being strange (Dunno) [Help]

Discussion in 'Mapping Questions & Discussion' started by mikeyX, Dec 1, 2015.

  1. mikeyX

    mikeyX L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    I know sprites are not the best but their effect is what I need for what I want to do.

    So I have an 128x128px sprite and a other 128x128px sprite.
    The first sprite is aligned with the env_sprite at the middle like this: Capture.PNG
    Because the env_sprite is at the middle, the sprite turns at the middle. (Like around it, dunno how to say it. #Bad English)

    The second sprite is different for no reasons. Just to say it already, both texture and material have the same flags, options, compilers, ect (The only thing changed is that, in VTFEdit, I resized using the "Point" resize filter to keep the "Pixel Art" style). The env_sprite, this time, putted the sprite in the bottom right of him, like this: Capture.PNG

    The thing is that the sprite is rotating using the top left, not making the same motion I wanted (And usually the motion I know from sprites). Its a big problem because I have other sprites but they are even more larger, so its pretty hard to not get them clip into a wall.

    That's pretty much it. Thanks for reading and helping if you know something. Also sorry if the english is bad.

    I might not instant reply. Thanks for understanding.
     
  2. MaccyF

    aa MaccyF Notoriously Unreliable

    Messages:
    908
    Positive Ratings:
    1,468
    not too sure how sprites work (never made a custom one myself), but if you have a vmt try adding the parameter

    "$basetextureoffset <x> <y>"

    failing that try

    "$basetexturetransform .5 .5 1 1 0 <x> <y>"

    edit: also, welcome to the site :)

    edit 2: what happens if you use a different resize filter instead of point?
     
    • Thanks Thanks x 1
  3. mikeyX

    mikeyX L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Before I even had the chance to try, the second sprite was in at the right place, but im having still the same problem with my other sprites. Im gonna do some tests with what you said and tell ya if everything is fine.
     
  4. MaccyF

    aa MaccyF Notoriously Unreliable

    Messages:
    908
    Positive Ratings:
    1,468
  5. mikeyX

    mikeyX L1: Registered

    Messages:
    3
    Positive Ratings:
    0
    Their preview became strange, so I decided to just redo them and it actually worked for, again, no reasons. But still Thanks for helping me ^^
     
  6. MaccyF

    aa MaccyF Notoriously Unreliable

    Messages:
    908
    Positive Ratings:
    1,468