engie crashing the map

Discussion in 'Mapping Questions & Discussion' started by ikem, Jan 9, 2009.

  1. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    when i load up the map and build something.. sentry, tele, dispenser and it gets destroyed (manually destroying or getting it killed) it crashes the server... anyone know a fix lol

    if u need to look at the vmf i can send it to u
     
  2. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    no one has anything.....
     
  3. Icarus

    aa Icarus

    Messages:
    2,246
    Positive Ratings:
    1,182
    Your control points may not be set up properly.

    I had this problem, too, because two of my control points had the same index

    Other than that check for leaks.
     
    • Thanks Thanks x 1
  4. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    well on the team control point ent the cap layout was "0 1"

    and the idexes of the points were "3 4" so i made it that. i'll see if that works

    and there are no leaks
     
  5. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    didnt work...
     
  6. GrimGriz

    GrimGriz L10: Glamorous Member

    Messages:
    774
    Positive Ratings:
    133
    I've never done a cp map, so I don't know if you can try this...but if you can, vis groups the team control point entities and recompile and run it. If you can build and destroy without it crashing the servers then, you'll at least know it's something to do with those.

    Also, I'd try to sit there with the console open and have someone else destroy the thing...just to see if i could catch an error message when it crashed.
     
  7. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    ok i checked the caps and they are fine i narrowed it down to displacements why would that be causing errors?
     
  8. GrimGriz

    GrimGriz L10: Glamorous Member

    Messages:
    774
    Positive Ratings:
    133
    the only time I've had probs with displacements is when I try and make them a func_detail
     
  9. Ezekel

    Ezekel L11: Posh Member

    Messages:
    818
    Positive Ratings:
    244
    ikem i had the exact same problem.
    i'm guessing you're problem is cos when the building dies it emits pieces of itself - which are moving collision-enabled objects.

    all i can suggest is deleting the displacements in question and making them again (doesn't have to be all displacements, just the ones on the map that cause the crash to occur).

    no idea why it happens. my theory is that for some reason one of the points on the displacement is getting set to an invalid value (e.g. infinity) for collision, but not for visibility.

    you'd probably get the same effect if you tried to shoot over/at/above the displacement with a demoman's grenades (sticky or normal)
     
    • Thanks Thanks x 1
  10. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    thats what i think i might have to end up doing ty
     
  11. grazr

    aa grazr Old Man Mutant Ninja Turtle

    Messages:
    5,436
    Positive Ratings:
    3,568
    Let us know if that fixes it...
     
  12. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    well i redid all the displacements in the map... and it is still broke... on the displacements and off. i made a sentry right on this ledge and blew it up and it crashed

    [​IMG]

    i will be willing to email the vmf if u think it is easy to fix...
     
  13. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,367
    What power are the displacements? I think (don't quote me) that the higher the power of the displacement, the more your resources are used to handle physics collision. This would explain why your game crashes when the sentry gun explodes--it can't handle it.

    I would suggest a few tests:

    play demoman and shoot some pipe bombs and stickies on the displacement surfaces. If the game crashes in the same way, reduce the power on your displacements. You shouldn't have to have anything above power 4, even though it does look better.

    If you simply can't reduce the power, make sure there is nodraw behind the displacement and then select your displacement and check the 'no physics collision' on the face edit options on the displacements tab. This probably is not the best solution, since now the displacement is non-solid to a player, but it should work.

    Otherwise, you're having a problem completely unrelated to what I think is happening in your map. Good luck!

    EDIT: Can you say exactly what kind of crash you're having? What does hl2.exe tell you when it crashes, or does it at all? That might help determine the problem.
     
    Last edited: Jan 10, 2009
  14. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    ok this is what i did...

    re-did all the displacements...
    added nodraws under all the displacements...
    changed them to a lower power
    and took out more detailed displacements...

    and so far it does not crash. lol
     
  15. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,367
    Good! Right?
     
  16. ikem

    ikem L6: Sharp Member

    Messages:
    268
    Positive Ratings:
    34
    yep tried on 3 different servers and computers and it is all ok