Displacement lighting oddly?

Discussion in 'Mapping Questions & Discussion' started by temion, Jul 17, 2010.

  1. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    Yet another help thread for today. I have a situation i can't figure out (again). Some of my displacements blend correctly, and some don't. All of them follow a power of 2, are sewn properly and use like textures (grass to ground & rockwall to forest).

    In the screenshot the embedded image is an area that doesn't work, the surrounding does. The exact same texture combination is used. How can i get the lighting to work right for all of them?
     
  2. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    No one knows? I tried setting the lighting scale on all the displacements to the same value and still no avail.

    Getting kinda frustrated here. :(


    edit: forgot to add it does this on a fast compile AND a full compile. :\
     
    Last edited: Jul 18, 2010
  3. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,767
    Positive Ratings:
    5,508
    It really looks like they aren't sewing. Did you confirm they are sewing by moving one away and then trying to sew them back?
     
  4. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    Just tried moving them around and bit and resewing, still no difference.

    I dont get this lighting effect in hammer if that makes any difference.
     
  5. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,767
    Positive Ratings:
    5,508
    Well Hammer doesn't have lighting ;) (well, it does, be we don't talk about that camera mode around here)

    I can't quite tell from the screenshot, are these displacements at significant angles from each other? i.e. wall and floor. It could just be that that is how they are lighting due to the local conditions/geometry.
     
  6. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    These are walls and floors rounded out. The working ones and non working ones. Also should point out that every plane is separate and not a cube set to power of 2.

    What bothers me is that it works in some places and not in others. I mean, one of the places it works is where the geometry travels into the skybox! but not always, and not always within the map.

    No compile errors, no hammer errors.


    It's something stupid I am overlooking most likely, i just can't think of what.
     
  7. temion

    temion L2: Junior Member

    Messages:
    77
    Positive Ratings:
    4
    Oh god... *bangs head on keyboard*





    Building cube maps fixed this. I knew it was something stupid!:blushing: