Custom Textures !!!!

Discussion in 'Mapping Questions & Discussion' started by Sarah, Aug 28, 2008.

  1. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    Wow, this has driven me insane. Seriously why does valve/source make it so complicated!?

    I've been trying to get a custom image into hammer basically. I couldn't get the image to save as a vtf *with* a transparent background retained, never the less I went ahead without it to test and opened VTFedit and created the vmt. I put both of them in to this path:

    tf/materials/custom

    Open up hammer located them and get the black and pink blocks of death. I've tried putting them in various main folders and sub folders to no avail. I have tried different settings with the vtfedit and .. basically I don't know where I am going wrong. I follow tutorials which say the normal "save it as tga then import in vtfedit" or "use ps plugin save it as vtf" "create a vmt" "put them in X folder".

    Yet somehow ? :(

    So here's what I'm asking, it's a big favour. Could someone kindly let me send them the texture, then convert it and make a vmt. Then explain which settings they used ? Because for weeks I've tried and failed. I sense it's the vmt but I'm not very clued up on what should be going on there and let the program do it automatically !!
     
  2. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    first, check all filenames, then when you're sure you've got them all right post the contents of the .vmt here so we can see if something is wrong.
    Also if you have photoshop you might want to download the plugin for it, its made my life 1000 times easier - you can get the plugin here
     
  3. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    ok vmt reads :

    "LightmappedGeneric"
    {
    "$basetexture" "Custom/bluehub"
    }


    I checked the names as well. I have a vtf plugin already for corel ps, which I'm using.
     
  4. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,739
    well that reads fine.

    The locations of that and the vmf are:
    /tf/materials/custom/bluehub.vtf
    /tf/materials/custom/bluehub.vmt

    If its got an alpha channel (and is a decal) you should add these:
    Code:
    	"$decal" 1
    	"$translucent" 1
    but I don't see why it should be purple checkers without them..
     
  5. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    So in that case vtf should be in materials/Custom/bluhub.vtf

    If u want transparency, add $translucent 1 in the vmt.

    EDIT: DAMMIT, Youme! :(
     
  6. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    Yeah this is my problem ! everything seems to be correct, it's to the power 2, it's a vtf, has it's vmt, is in the right folder path yet ... :confused:

    For now I'm just leaving the custom ones out and working on other things, because as much as I've tried and double checked everything a million times, I can't get them to work.

    edit: It doesn't have the transparency layer yet, when I saved it in ps it just formatted to a white background, so that's not the concern for now. (I'll work out how to do that in ps later) but as a normal standard 512x512 texture it's not working in hammer.
     
    Last edited: Aug 28, 2008
  7. FaTony

    FaTony Banned

    Messages:
    902
    Positive Ratings:
    160
    Tried refreshing SDK content?

    Again, place it in steamapps/accountname/team fortress 2/tf/materials/custom
     
  8. AWESOME-O

    AWESOME-O L10: Glamorous Member

    Messages:
    782
    Positive Ratings:
    66
    sure something did not went wrong while creating the texture, saved with wrong specs orso?