Custom Textures And Cubemaps Problem

Discussion in 'Mapping Questions & Discussion' started by Sarah, Jan 27, 2009.

  1. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    I'm going out of my mind, I did a forum search and found this old thread :

    http://forums.tf2maps.net/showthread.php?t=4943&highlight=custom+textures

    It sounds like the same problem but there was never an answer or solution !

    Here's what I've tried: (I've followed the process to build cubemaps found on another thread here and on wiki.)

    1.After compiling, saving my custom textures (pakrat) to the bsp and saving with the same map name. Then building cubemaps (following the right process, reloading it all at the end etc).

    2.Same as 1 only I changed the map name when I saved in Pakrat.

    3. After compiling, building cubemaps, then adding custom textures. Saved under the same map name.

    4. Same as 3 only changing the map name once adding the textures in pakrat.

    Basically which ever way round I do it I either end up with cubemaps that work but no textures or textures but no working cubemaps. How are people doing this ?! Who has successfully finished a map with custom textures and working cubemaps (using pakrat) ? Can they please give a detailed step-by-step as to which way they did it ?

    Easy solution is to take the custom textures out but it annoys me that other people have done this successfully somehow !! Why are custom textures such a nightmare with hammer ? WHY GOD WHY !?! :laugh:
     
  2. Vigilante212

    Vigilante212 L7: Fancy Member

    Messages:
    481
    Positive Ratings:
    33
    At this point youll need to recompile the map for it to work. Recompile, then pack the textures then buildcubemaps. Im assuming you know the proper way to build cubemaps so i wont explain it. And dont rename the map afterwords. Changing stuff after its packed tends to goof up packrat stuff not sure why.
     
  3. Sgt Frag

    Sgt Frag L14: Epic Member

    Messages:
    1,443
    Positive Ratings:
    294
    You might be doing things in the wrong order. I haven't done them like you and I have been successful in this.

    1st. save map under the name you will release it as.

    2nd. compile, build cubemaps.

    3rd. pakrat, save same name.

    4th. get rid of all custom stuff you used, test to make sure it's there in game (verify pakrat successful)

    that should be it, don't ever rename after compile. (that'll mess up cubemaps which are built under the compile name).
    --------------
    also, the map gets saved in 2 spots. source_content folder and teamfortress/tf/maps folder. after cubemaps are built the source_content one will be smaller as it doesn't have cubemaps in it.
    Make sure you pakrat the correct file.
     
  4. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    Thanks for the replies but I've done that, it's what I did originally. Only reason I tested saving the map under a different name afterwards was because the other way wasn't working and someone suggested changing it when I add the textures. Which did in fact save them in the bsp. Just didn't work for the cubemaps. Never mind I'll just take all the custom textures out and be done with it.
     
  5. GrimGriz

    GrimGriz L10: Glamorous Member

    Messages:
    774
    Positive Ratings:
    133
    In the original thread he talks about linking textures to cubemaps...I've never had to do that with my custom textures (though they weren't reflective customs).
     
  6. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,366
    Noooo!!! Don't forsake the custom materials!!!

    Keep trying to fix the issue--

    http://forums.tf2maps.net/showthread.php?t=4530&highlight=cubemaps

    The only thing I can think of is that something is wrong with pakrat when it saves the .bsp after packing the materials in, or that something is wrong with your .vmt parameters. Will you post a sample here of your .vmt's parameters? I'd like to see this issue resolved, especially such a bizarre one. But just taking out all the custom stuff isn't a better option. We'll fix this!

    ALSO: Are you using HDR? Because that can cause some interesting things with cubemaps if you're not doing it right.
     
  7. Sarah

    Sarah L1: Registered

    Messages:
    42
    Positive Ratings:
    0
    Ok thanks to Big Rexy I gave it one last try and somehow .. I'm not sure how but it worked. They only thing I can really think I did differently was not setting sv_cheats 1 and sv_lan 1 when I built the cubemaps. I pretty much went through it step by step slowly making sure I followed everything to the T.

    I compiled in hdr, I saved it all with the same name. I manually added the textures in pakrat and then built the cubemaps following the exact process in the 'cubemap' thread linked here. I'm shocked that whatever tiny thing I did differently has suddenly made it work. I'm kind of baffled as to why it didn't in the first place ! ?

    anyway thanks alot Big Rexy , you didn't give me a solution as much but made me not give up :) !
     
  8. Rexy

    aa Rexy The Kwisatz Haderach

    Messages:
    1,795
    Positive Ratings:
    2,366
    Lol thanks for the thanks even though I just told you to try again. Thank Cameron's tutorial if anything. Use the thanks button!