Custom skybox wrapping problems

Discussion in 'Mapping Questions & Discussion' started by not_a_zombie, Feb 24, 2016.

  1. not_a_zombie

    not_a_zombie L1: Registered

    Messages:
    1
    Positive Ratings:
    0
    I'm trying to create a custom skybox for a map I'm making, but the textures don't wrap properly in game - it's as if there's a row of pixels missing from each edge of the texture.

    [​IMG]

    I'm not sure what's causing this problem - the images wrap just fine when spliced together, and I'm using the same settings as a skybox that I know works (Clamp S, Clamp T, Hint DXT5, No mipmap, 8 bit alpha in the vtf, and UnlitGeneric, nofog and ignorez in the vtf).

    What's causing this problem and what can I do to fix it?
     
  2. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    It looks fine to me. Though at the same time, I have no idea what I'm really looking at. Maybe posting the original textures here so we can see what it's supposed to look like would help. Is the problem that it looks like the skybox is tilted? It looks like you are trying to go for a more "trippy" look, which in this case it works.
     
  3. killohurtz

    aa killohurtz Distinction in Applied Carving

    Messages:
    1,003
    Positive Ratings:
    1,152
    Come to think of it, I noticed something similar when editing the alpinestorm sky a while back, but since it looked fine in-game I didn't pay it any mind at the time. See how there's a faint 1px seam around the edge of each image when they're stitched together? If you look closely at the mountain slope on the left side, you can tell it's not continuous, like the seam is breaking it up by a couple of pixels. So my best guess is that the engine just treats all skies like this, and you'll have to leave 1px borders on your own images to compensate.

    [​IMG]
     
    • Useful Useful x 1