1. On August 16th at 9pm CST, the site will be put in to read only mode for maintenance. Maintenance should not take longer than an hour.

Custom Audio Problems

Discussion in 'Mapping Questions & Discussion' started by Nicky, Mar 12, 2016.

  1. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    I'm working on my April Fools map, which uses custom sounds. I have a lot of them, and they are all saved/exported under the same settings, and most of them work in game. However some of them dont, and I am told in the console that they have a bad sample rate. I've tried exporting them as the correct rate (44100) but it still gives me the error. Does anyone know a way t fix this, or maybe a program that can tell me what the sample rate for the audio file actually is?

    Screenshot (42).png

    What I'm told in Audacity:
    Screenshot (44).png
     
  2. Izotope

    aa Izotope Never releases maps

    Messages:
    619
    Positive Ratings:
    584
    Simple, don't change the sample rate where you've been changing it, only change it on the bottom left. (At least it's there for me)
    [​IMG]
     
  3. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    @Izotope
    Yeah I forgot to mention it's set there as 44100, I even set the default project rate in my preferences to be 44100 specifically for making sound for maps and sfm. I even tried completely remaking the sounds from scratch, but it still doesn't work.
     
  4. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    368
    Positive Ratings:
    278
    You need to set the sampling rate when exporting the file, if my audacity knownledge serves me right. Set the file format to Windows 16-bit or something wav, and in the properties (accessed by pressing the "properties" button) set the sampling rate to 44100hz. The in-audacity sampling rate doesn't affect the exported sampling rate directly, I think.
     
  5. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    So can I only use wavs? Or afterwards can I export it back as a mp3 as it saves a lot of space. And I'm also having trouble finding this "properties" button, could you post a screenshot of it? Or at least tell me where I can find it?
     
  6. Dr. Orange

    Dr. Orange L6: Sharp Member

    Messages:
    368
    Positive Ratings:
    278
    [​IMG]
    I'm using non-english language settings, but it should still be there.
    However, it seems like wav doesn't have export options, so I guess just exporting it as wav should work.
     
  7. Nicky

    aa Nicky Lets try something new!

    Messages:
    912
    Positive Ratings:
    1,698
    I do not have a button there. Was there an update to audacity that I missed, like did you recently just install it?
     
  8. Izotope

    aa Izotope Never releases maps

    Messages:
    619
    Positive Ratings:
    584
    These settings aren't available for WAVs, though, only for MP3 and other formats, and it's not even sampling rate settings.
    Make sure you have these quality settings:
    [​IMG]

    If all else fails you could post your sounds here and somebody will get the right sample rate for you.
     
    Last edited: Mar 12, 2016