Curious map issue, entities not firing correctly

Discussion in 'Mapping Questions & Discussion' started by YM, Jul 29, 2012.

  1. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,741
    I suspect this may have something to do with swapping to SFM's SDK or using VBCT to compile, or both, here's the issue:

    All of my entities that fire any kind out output in strata are firing, but only firing .use() instead of whatever they're supposed to fire (like .open() or .close() for doors or .setskin() for capture points) So every entity in strata is broken, no doors work, no setup gates drop, no respawn timers are set, no tonemap settings are set. Useless.

    Then there's the problem of the actual entity names, I can trigger anything through ent_fire but any entity sending an output sends it to <corectname>disable0-1 or some similar, incorrect name.

    Has anyone experienced this kind of issue before?
     
  2. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,741
    All right here's what it is:
    SFM era VMFs and BSPs uses a totally different method for outputs as pre-SFM era VMFs so when compiling with pre-SFM VBSP it doesn't know what to do and so fudges all the outputs, thus nothing works.

    There is no fix beyond some awkward splicing previous versions of maps with gameplay entities with current versions of the maps with static entities and brushes.

    So the bottom line is: For the love of god please don't open your TF2 maps in SFM hammer just for curiosity. You WILL regret it.
     
    • Thanks Thanks x 2
  3. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,032
    Positive Ratings:
    3,978
  4. Jeremy

    Jeremy L11: Posh Member

    Messages:
    829
    Positive Ratings:
    251
    aw shiet