Control Point HUD Layout

Discussion in 'Mapping Questions & Discussion' started by Half-Life_Maniac, Nov 30, 2007.

  1. Half-Life_Maniac

    Half-Life_Maniac L3: Member

    Messages:
    122
    Positive Ratings:
    88
    Hello,

    My first problem for you is so;
    I've got 5 command points which I want to layout on the HUD sort of like this:

    1_2
    _3_
    4_5

    Instead of the usual 1 2 3 4 5

    I know that I'm supposed to use the "cap layout" field of the team_control_point_master, but I've only got strange results so far. The format I've used is "1 2,3,4 5"
     
  2. boooooom3

    boooooom3 Guest

    Positive Ratings:
    0
    The CP index starts with a "0", not with "1".
    So it should be "0 1,2,3 4". :)
     
  3. Half-Life_Maniac

    Half-Life_Maniac L3: Member

    Messages:
    122
    Positive Ratings:
    88
    That's only if you actually gave your first cap point an index of 0. My first starts at 1.
     
  4. boooooom3

    boooooom3 Guest

    Positive Ratings:
    0
    Try to make your CPs start at 0 then.
     
  5. Hampster

    Hampster L1: Registered

    Messages:
    8
    Positive Ratings:
    0
    Try using the square brackets, e.g. <1 2, 3, 4 5>
     
  6. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,531
    You must start at 0. It's just the way it's coded (and lots of code related things like to have stuff start at 0)
    Brackets are not needed, they just used them in the entity description.
     
  7. Half-Life_Maniac

    Half-Life_Maniac L3: Member

    Messages:
    122
    Positive Ratings:
    88
    Well, my current test map has the first cap point with an index of 1, and I have not seen any problems so far. I used an index of 0 in the past (since I did read somewhere that you should) but that was before I redid all my points and got them working. I'll see what happens if I do use 0...

    Also, A Boojum Snark- I remember you from teh VERC!

    [UPDATE] Well, would you look at that. It actually works! Got the HUD, and my non-linear cap points are still working.
     
    Last edited: Dec 2, 2007
  8. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,531
    Heh, now that you mention it I do vaguely recall someone of your name over there. :)
     
  9. Shmitz

    aa Shmitz Old Hat

    Messages:
    1,129
    Positive Ratings:
    740
    Actually, checking Valve maps, they start their indexes at 1, not 0.

    Incidentally, I don't know if this has anything to do with your problem getting fixed, but I noticed on gravelpit the new line had a space after the comma, while the sequence in your original post has no spaces after the commas. It may just simply be a matter of parsing.
     
  10. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,531
    Curious. If it is the spacing that's the problem I wonder why making it 0 seems to fix it too. (I had this same problem...)
     
  11. Half-Life_Maniac

    Half-Life_Maniac L3: Member

    Messages:
    122
    Positive Ratings:
    88
    I used the same string as posted above. All I changed on the map is the index of each of the command points (starting at 0).