Compiler seeing no existent leaking entity

Discussion in 'Mapping Questions & Discussion' started by DJ Sylveon, Apr 24, 2016.

  1. DJ Sylveon

    DJ Sylveon L3: Member

    Messages:
    101
    Positive Ratings:
    20
    So basically I was re working a map and changed its skybox and decided to make sure I wasn't getting leaks. I did the BSP compile only and it said it found a leak for a trigger_hurt outside of the skybox so I check the location the compiler gave me. Nothing was there. I even made sure by selecting the area and clicking around. I open the point file. Pointed to the spot it thought it was at and then pointed straight up. There is only one real trigger_hurt on my map and that is well inside the map. Any ideas how to fix this?
     
  2. zahndah

    aa zahndah professional letter

    Messages:
    718
    Positive Ratings:
    627
    the origin would be outside the map. To fix this, go into 'groups' selecting mode and select the trigger_hurt. Then if you zoom out on all your 2D views, you will see a little circle outside the map where it says it is leaking. drag that back to the trigger hurt and you will be golden.
     
  3. YM

    aa YM LVL100 YM

    Messages:
    7,099
    Positive Ratings:
    5,745
    trigger_hurts, and many other brush entities (but not all) have an origin.
    use :helpers: to turn helpers on, then select the brush, you should see a blue sphere. Drag that sphere back into the brush. Alternatively use tools > 'centre origins' with the brush selected.
     
  4. DJ Sylveon

    DJ Sylveon L3: Member

    Messages:
    101
    Positive Ratings:
    20
    Nope. The circle is within the trigger_hurt. I checked the other triggers too and they all have their circles in them.
     
  5. DJ Sylveon

    DJ Sylveon L3: Member

    Messages:
    101
    Positive Ratings:
    20
    Found it. Leak fixed.