Compile times are through the roof

Discussion in 'Mapping Questions & Discussion' started by Chromatose, Sep 17, 2013.

  1. Chromatose

    Chromatose L1: Registered

    Messages:
    33
    Positive Ratings:
    0
    So the issue I am having is my compile is taking absurdly long to complete. HDR is off, I've been using func_detail around the map, with the exception of a few, most of my lights do not have names or additional functions beyond being a certain colour and lighting up a certain place. It has taken 5 hours for the map to compile to this point: http://i.imgur.com/8Vhd2B5.png

    There surely has to be a way to get this to run faster, this is insane. Thanks in advance.
     
  2. Fantasma

    aa Fantasma

    Messages:
    888
    Positive Ratings:
    995
    hmm, usually after a while vvis takes a while.
    If you want it to compile faster, turn it off.
    Other than that I can't help you much (someone else could)
     
  3. Chromatose

    Chromatose L1: Registered

    Messages:
    33
    Positive Ratings:
    0
    Thanks for trying. I will try running with vvis off but since I am hoping to render a functional .bsp for a server it probably wont be the best idea. I removed all animated lights and this has made a slight improvement but my compile times are still a pain.
     
  4. Crash

    aa Crash func_nerd

    Messages:
    3,191
    Positive Ratings:
    5,017
    Do a fast compile and then go to Map > Load Portal File.

    If there is a crazy amount of blue lines, especially concentrated around certain areas, you'll have to do some more func_detailing, and this is probably why it's taking so long.

    Other than that, I'm not sure what would increase your time. 5 hours is never normal, so there has to be an issue on the map somewhere making it take longer.
     
  5. Beetle

    Beetle L9: Fashionable Member

    Messages:
    627
    Positive Ratings:
    174
    You did say you have a ton of water in your map. That could be what's making it take longer
     
  6. DonutVikingChap

    DonutVikingChap L5: Dapper Member

    Messages:
    228
    Positive Ratings:
    142
    Make sure all your blockbullets brushes are func_detailed. I had this issue in my map, it was stuck on VVIS and wouldn't compile at all, so I loaded the portal file and saw that all my complex blockbullets brushes were making hundreds of visleaves.
     
  7. A Boojum Snark

    aa A Boojum Snark Toraipoddodezain Mazahabado

    Messages:
    4,769
    Positive Ratings:
    5,535
    For the record, VBSP is the one that generates the portal file. If that is all you want you can just not even run VVIS and VRAD.
     
    • Thanks Thanks x 1