Compile freezes at "Building Physics Collision Data..."

Discussion in 'Mapping Questions & Discussion' started by HarMala, Sep 16, 2012.

  1. HarMala

    HarMala L1: Registered

    Messages:
    28
    Positive Ratings:
    1
    Hiya, I was working on my first map like a month ago but I got fed up with compiling it: I had just fixed all my leaks and I tried to compile my map but every time compiling freezed at "Building Physics Collision Data...".
    So this week I really wanted to work on my map again but I realized that Im still having that same problem. Is there something wrong with my map or should I just wait longer? Help me out guys.
    Since I cant copy my compile log, heres a screenshot if it helps (taken after 3+ hours of compiling):
    [​IMG]
    "Ei Vastaa"= "Not Responding"

    Thanks :)
     
  2. GPuzzle

    GPuzzle L9: Fashionable Member

    Messages:
    638
    Positive Ratings:
    200
    Holy Mackarel, there is some how so many things. I mean, there is so many stuff I guess your computer just crashed hammer.
     
  3. Faux Rhinoceros

    aa Faux Rhinoceros Also known as Dr. Element

    Messages:
    1,481
    Positive Ratings:
    1,583
    Try to close in on where the problem is, by turning off the model/func_detail visgroups, and see if the compile still fails.
     
  4. tyler

    aa tyler snail prince, master of a ruined tower

    Messages:
    5,035
    Positive Ratings:
    4,497
    What power are your displacements? You should be using power 2 99% of the time and power 3 rarely, if ever. I'm gonna guess you're using power 4?
     
  5. HarMala

    HarMala L1: Registered

    Messages:
    28
    Positive Ratings:
    1
    Nope, Ive learned my lesson with power 4. All my displacements are power 3. So I guess I should change them to power 2 then...
     
  6. HarMala

    HarMala L1: Registered

    Messages:
    28
    Positive Ratings:
    1
    So I changed the power of all my displacements to 2 and I tried to compile. Now it doesnt freeze right at "Building Physics Collision Data..." but right after it at :
    "Building Physics Collision Data...
    done (0) (713404 bytes)"

    Any help? :confused:
     
  7. HarMala

    HarMala L1: Registered

    Messages:
    28
    Positive Ratings:
    1
    I tried to compile without displacements, func_details and props, but the compiling still fails. Looks like it freezes at "BasePortalVis"

    Anyone? :confused:
     
  8. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    500
    Are you sure the build process is actually failing? The Hammer compile window loves to "freeze" if you alt+tab away from it or basically do anything else with your computer. The compile is still running in the background, you just aren't getting any text updates.

    Maybe give VBCT a shot at compiling your map, at the very least you'll get more immediate feedback.

    My suspicion is the huge delay is actually being caused in the VVIS stage.
     
    • Thanks Thanks x 1
  9. HarMala

    HarMala L1: Registered

    Messages:
    28
    Positive Ratings:
    1
    I tried to compile for over 3 hours without even touching my computer, and it didnt get past "Building Physics Collision data..."


    I downloaded VBCT and tried to compile and guess what? IT WORKED! Many thanks to you! :wow:
     
  10. xzzy

    aa xzzy

    Messages:
    815
    Positive Ratings:
    500
    It's nice that it got you a successful compile, but VBCT doesn't really do anything special. It uses the same binaries Hammer does, it just deals with the output a little differently. It might also use some different command options.

    Point being there still may be a problem with your map, but VBCT could be concealing it from you.

    So be on the lookout for glitches or performance problems.. if you find them, that's probably what Hammer's compile process was getting stuck on.